2

In the past (TeXworks v0.4.0 r.759 / MikTeX 2.9) I used the following texify option to inform texify about the location of additional input files:

--tex-option=-include-directory=C:\TexInputFiles\

This also caused bibtex to find extra .bib files.

Now, with version 0.4.6 (MiKTeX 2.9 64-bit), the same texify option only lets the latex pass find additional styles and other input files. There is a LaTeX Warning complaining about "Empty 'thebibliography' environment on input line XX" and bibtex reports (in the .blg file): "I couldn't open database file XXX".

I can use -include-directory=C:\TexInputFiles\ for pdfLaTeX and for BibTeX individually and then invoking the passes manually delivers the desired result, i.e., bibtex finds the .bib files.

However, it seems that texify used to pass on the "--tex-option=" value to bibtex as well as latex but only does so now for latex. Is that possible?

Is there any chance to fix that or is there a workaround?

I tried setting the environment variables BIBINPUTS and TEXINPUTS to C:\TexInputFiles\ (and C:\TexInputFiles\) (in System | Environment Variables | System variables) but under Windows environment variables always seem to be ignored.

  • Well with --tex-option you are passing options and so the include-dir to the tex engine. So I do find it curious that it ever worked for bibtex too. Why don't you use texify --include-directory=C:\TexInputFiles\ file ? – Ulrike Fischer Feb 15 '16 at 12:45
  • Hi Ulrike, thanks heaps for your reply!!! I did not try "--include-directory" for texify directly because this command option is not mentioned in any documentation for texify that I found. However, based on your tipp, I tried it and it worked! Many, many thanks!!! – Class A Feb 15 '16 at 12:57
  • In my (current) miktex texify knows --include-directory. Did you try? You can see the option when you do texify --help on the command line. – Ulrike Fischer Feb 15 '16 at 12:57
  • The documentation mentions the shortcut -I: docs.miktex.org/2.9/manual/texify.html – Ulrike Fischer Feb 15 '16 at 12:59
  • Hi Ulrike, a thousand thanks again. I have edited my original comment to thank you for alerting me to --include-directory for texify. I tried it and it does work! Note, however, that even in the link you posted, the --include-directory option is not documented. I looked at the same file, just a local copy of it. – Class A Feb 15 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.