4

We are having issues with Adobe ADS version 1040.20121017114537.881796 signing documents. We can confirm that it can sign Adobe pdf version 1.6 documents internally generated. It cannot sign eforms or digsig documents. These are pdf version 1.5 documents.

Has anyone else experienced this issue? Hope this is not off-topic for this site.

Is there any Latex package available than can create Adobe pdf version 1.6 signature fields?

Minimal digsig sample:

\documentclass{article}
\usepackage{digsig} % <-- the driver is pdftex or xetex
\pdfminorversion=6
\begin{document}
  \digsigfield{5cm}{1cm}{test}
\end{document}

Minimal eforms sample:

\documentclass{article}
\usepackage{eforms}
\pdfminorversion=6 
\begin{document}
  \sigField{test}{5cm}{1cm}
\end{document}
  • 2
    What happens if you put \pdfminorversion=6 in the preamble? Sometimes applications check the version number, but don't act on the information in any significant way, so simply telling the system that your file version is pdf 1.6 might solve the problem. – Ian Thompson Feb 15 '16 at 13:26
  • I can confirm that %PDF-1.6 is produced for both packages. Testing further... – skvery Feb 15 '16 at 19:01
  • I can confirm that digsig sample above is working and eforms not. @Ian can you post your solution please? – skvery Feb 18 '16 at 8:43
1

We could only get the following digsig sample to work:

\documentclass{article}
\usepackage{digsig} % <-- the driver is pdftex or xetex
\pdfminorversion=6
\begin{document}
  \digsigfield{5cm}{1cm}{test}
\end{document}

I can also confirm that the following does not work with this specific version of ADS:

\documentclass{article}
\usepackage{digsig} % <-- the driver is pdftex or xetex
\pdfminorversion=6
\begin{document}
  \begin{Form}
    \digsigfield{5cm}{1cm}{test}
  \end{Form}
\end{document}

This specific version of ADS seems to be very buggy.

  • Neither of these allow me to sign the document produced. Using adobe reader 9 on 14.04 Ubuntu. Properties shows "Signing: Not Allowed" – A Feldman Feb 18 '16 at 12:46
  • I tried using the 2015 version of texlive. – A Feldman Feb 18 '16 at 12:53
  • As far a I know only Adobe Reader 11.0.7 or later can sign documents. All the samples work in Reader 11.0.14. (I generated the pdf on SageMath Cloud by uploading eforms or digsig) – skvery Feb 18 '16 at 18:09
  • There seems to be provision in Linux Adobe Reader 9 for certificates, timestamps, and digital signatures. It just seems that I produced a pdf that could not be signed (as per the properties dialogue). I wish I knew what I am doing wrong. – A Feldman Feb 18 '16 at 22:01
  • Tried with 9.5.5 in Linux. Cannot add signature to signature field. – skvery Feb 19 '16 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.