0

I have to make a presentation in LaTeX, the beamer themes have now become mundane.

So, I have two questions:

  1. I tried to use the Stockholm template. I downloaded the zip from here. I was unable to even compile it in LaTeXila and TeXmaker (Ubuntu). There are only 2 errors but I can't figure them out (I am not posting the errors).

    Click here for the template at overleaf (Just click download as zip button on the left hand side panel).

With Latexilla the errors are:

You have requested package `beamercolorthemesthlm',but the package provides `beamercolorthemev42'.

You have requested package `beamercolorthemesthlm',but the package provides `beamercolorthemev42'.   

File `newpxtext.sty' not found.
  1. Are there any newer presentation templates for beamer ?

Thanks

16
  • Anything that would be helpful in this case is heartily welcome, I dont want to make another presentation in ...
    – ferrer
    Commented Feb 16, 2016 at 9:54
  • Hi. It would help a lot, if you posted the errors and a MWE of your template. A first issue for me is that \usetheme{sthlm} of the linked template is not found: Where is it pprovided or where can it be obtained? Commented Feb 16, 2016 at 10:00
  • @HATEthePLOT will the edit help ?
    – ferrer
    Commented Feb 16, 2016 at 10:06
  • I just use beamer with no 'theme' at all: really these things are better suited to sales pitches than academic presentations
    – Joseph Wright
    Commented Feb 16, 2016 at 10:07
  • @JosephWright yes I agree, but will everybody using fancy ppts -- some use prezi and 3d ppts for academic presentations as well -- I too want to improve my presentations -- step by step
    – ferrer
    Commented Feb 16, 2016 at 10:14

2 Answers 2

2

The first error

You have requested package `beamercolorthemesthlm',but the package provides `beamercolorthemev42'..   

is just a naming error in the theme. Meaning the filename doesn't match the name given in the \ProvidesPackage{} command. This should not prevent you from typesetting a presentation with it.

The actual problem seems to be, that you don't have the newpx package installed which the theme uses. So please update your packages:

How do I update my TeX distribution?


EDIT: If you cannot, because of whatever reason, update your packages and install newpx you can also remove the newPxFont option when loading beamer. So replace:

\documentclass[newPxFont,sthlmFooter]{beamer}

with

\documentclass[sthlmFooter]{beamer}

in the template file. This way the newpx package will not be used.

3
  • I get the error: newpxtext.sty not found ...
    – ferrer
    Commented Feb 16, 2016 at 11:20
  • Still? Even though you updated all your packages with tlmgr update --all?
    – Benjamin
    Commented Feb 16, 2016 at 11:21
  • I think I spotted the problem: The template provides ty files as well which I oversaw at first. However, the sty-files from the github repo I posted are working fine. The ones from the original template provided by ferrer are different. Commented Feb 16, 2016 at 11:41
2

The provided template needs specific sty-files that can be obtained at this Github-Repository. They need to be extracted into the project-folder to seccessfully compile the template.

5
  • any more files you needed to add to the project ? The repo itself is not working .. same errors.
    – ferrer
    Commented Feb 16, 2016 at 10:39
  • Just for understanding: You have your project file from the template you linked in your first post. In the folder where you saved the presentation you unzip the github files. Then you compile the presentation template from your first link. It should work fine. sty-files are not to compile. Commented Feb 16, 2016 at 10:42
  • Thanks, its not working for me strangely....
    – ferrer
    Commented Feb 16, 2016 at 10:47
  • Do you have all files in the same folder? The sty-files need to be in the same folder and not a subfolder. I tried it on three machines (Ubuntu, Windows and Windows, texlive2014 and 2015). ist works without problems. Commented Feb 16, 2016 at 10:53
  • yes, they are in the same folder. I don't see any difference between the github repo and the template I posted. 3 .sty files in both. ARe you sure the github link repo isn't the same ?
    – ferrer
    Commented Feb 16, 2016 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .