1

I have recently (about a week) updated the operating system from windows 7 to windows 10. As for this moment, any use of the fontspec or polyglossia packages won't compile.

After the problem occurred, I have updated Miktex using both the admin and non-admin options. I have also tried "refresh FDNB" and "update formats" in the Miktex "Setting" tool (both admin and non-admin). However, the problem was not solved.

I have uninstalled and installed Miktex 2.9 again. After installation I have updated Miktex (both admin and non-admin) and applied "Refresh FDNB" and "Update Format" in the Miktex "Setting" tool. Yet, the compilation error continues.

An example code:

\documentclass{article}
\usepackage{fontspec}
%\usepackage{polyglossia}

\begin{document}
    This is a new document!
\end{document}

When compiling the above code using XeLaTeX (Miktex 2.9 and TexStudio) I get the following massages: linked file.The log file is linked here.

Any help in this matter would be very appreciated.

  • 1
    Show the complete log of your example (exactly this example!) – Ulrike Fischer Feb 16 '16 at 22:27
  • @Ulrike Fische Thanks for your reply. I have reedited the question and included links to both the log file and the messages given by the editor. – AKosman Feb 18 '16 at 15:07
  • Your system is not up-to-date. The files in "C:\Program Files (x86)\MiKTeX 2.9\ are new and ok, but the files in C:\Users\Avraham\AppData\Roaming\MiKTeX\2.9 are too old. Run in your user account the update manager (not the update manager (admin)). – Ulrike Fischer Feb 18 '16 at 15:21
  • @Ulrike Fischer. Thanks again. I ran the update manager as you suggested, then ran the "Refresh FDNB" and "Update Formats" in "Miktex Settings". The problem remains. – AKosman Feb 18 '16 at 15:58
  • Did the update manager show any updates? – Ulrike Fischer Feb 18 '16 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.