1

I want to cite a website link as a reference using apalike bibliographystyle.
I have to use apalike as requested by the conference.

Here is the code:

\documentclass[times,10pt,twocolumn]{article}
\usepackage{PRADSConference}
\usepackage{times}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage[draft]{hyperref}
\usepackage{url}
\usepackage{authblk}
\pagestyle{empty}
\usepackage[round]{natbib}
\bibliographystyle{apalike}
\usepackage{amsmath} 
\usepackage{cleveref} 

\citep{lithium}
\bibliography{refs}
\end{document}

However, The output is not numbered as the rest of references as shown below

enter image description here

I wrote the reference in the bib file as follows

@Misc{lithium,
Title                    = {Lithium-ion Specifications},
HowPublished             = {\url{http://optimum-china.en.alibaba.com/product/437274726-212297973/rechargeable_HEV_EV_bus_battery_pack_of_lifepo4_600v_500ah.html}},
Note                     = {Accessed on: 10/02/2016}}

I also receive this error:

package natbib error bibliography not compatible with author-year citations

when I remove the website link reference from the .tex file, No errors are there and all reference are shown in author-year style as it should be as shown in picture

enter image description here

  • If your citation should be apa like, you would get a author-year style, not a numbered one. change the content of the braket from round to authoryear. – Johannes_B Feb 17 '16 at 17:02
  • @Johannes_B when I remove the website reference from the tex file, No errors are there and all reference appear in author-year style as it should be with changing 'round' to 'authoryear' – Ameen Mohamed Bassam Feb 17 '16 at 17:11
  • @Johannes_B The error appears when I put the reference as I wrote in my question. – Ameen Mohamed Bassam Feb 17 '16 at 17:13
  • @Johannes_B - It turns out the natbib-generated error is somewhat less than helpful. (But then, many TeX and LaTeX error messages aren't particularly helpful...) Fundamentally, the problem arises because the entry is lacking both an author and a year field; hence, natbib issues a (misleading) warning. – Mico Feb 17 '16 at 17:16
  • 1
    @AmeenMohamedBassam - In the case of url, hyperref, and cleveref, the anwer is, most definitely. Incidentally, you should be setting the option hyphens when loading the url package. Give it a try, and I think you'll notice a big difference. – Mico Feb 17 '16 at 17:56
2

The apalike bibliography style is designed to create authoryear-style citation call-outs. However, the lithium entry is lacking both the author field and the year field. What is poor natbib -- at heart a citation management package -- supposed to do?

I suggest you create suitable author and year fields for the lithium entry, delete all aux files, and recompile your document fully (LaTeX, BibTeX, and LaTeX twice more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.