9

I use MiKTeX 2.9 and TexStudio 2.10.8 as my editor. And I try to use biblatex/Biber

I have installed Biber with the packackge manager of MiKTeX and configured TexStudio to use Biber.

This is the important part of my LateX file, which is about Biber:

\usepackage[style=authoryear, backend=biber]{biblatex}
\addbibresource{referenzen.bib}

So when compiling TexStudio shows me this error:

INFO - This is Biber 2.3
INFO - Logfile is '<mylatexfile>.blg'
INFO - Reading '<mylatexfile>.bcf'
WARN - Warning: Found biblatex control file version 2.6, expected version 2.9
INFO - Found 1 citekeys in bib section 0
INFO - Processing section 0
INFO - Looking for bibtex format file 'referenzen.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8
INFO - Found BibTeX data source 'referenzen.bib'
INFO - Overriding locale '' defaults 'normalization = NFD' with 'normalization = prenormalized'
INFO - Overriding locale '' defaults 'variable = shifted' with 'variable = non-ignorable'
INFO - Sorting list 'nyt' of type 'entry' with scheme 'nyt' and locale ''
INFO - No sort tailoring available for locale ''

\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber/SortLists.pm line 77.

Use of uninitialized value $pre in regexp compilation at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber/Internals.pm line 1000. Use of uninitialized value $thislocale in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 2856. Use of uninitialized value $thislocale in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 2943. Use of uninitialized value $thislocale in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 2948. Use of uninitialized value $lname in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 1979. Use of uninitialized value $lssn in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 1979. Use of uninitialized value $lssn in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 1993. Use of uninitialized value $lssn in concatenation (.) or string at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber.pm line 2008. Can't use an undefined value as an ARRAY reference at D:\Users\<username>\AppData\Local\Temp\par-<num>\cache-19a661c7206c3f371c207b98ac69231301395587\inc\lib/Biber/Internals.pm line 990.

I noticed the warning about the biblatex control file and therefore I looked in the package manager MiKTeX what's the version of biblatex: Biblatex version 2.9a

And surprisingly it is called v2.9 and not 2.6 there. So to verify this version error I looked into my .bcf file and it indeed is labeled v2.6 there:

<?xml version="1.0" encoding="UTF-8"?>
<bcf:controlfile version="2.6" xmlns:bcf="https://sourceforge.net/projects/biblatex">
  <!-- BIBER OPTIONS -->
[...]

So why is there this version discrepancy and how can I get it to compile correctly?

  • Did you compile the project with an old version of biblatex? What does your editor say if you compile it from scratch (i.e. delete all project related files except your .tex-file?) – HATEthePLOT Feb 17 '16 at 23:39
  • Welcome! Usually, you just need to remove the generated files and recompile from scratch as @HATEthePLOT suggested. – cfr Feb 17 '16 at 23:41
  • 1
    The version of biblatex does not coincide with the biblatex control file version. (The version numbers of these two are stepped up independently.) It is just coincidence that Biber 2.3 asks for bcf version 2.9 and you have biblatex 2.9a installed. Both the Biber and biblatex manual feature a compatibility matrix stating that Biber 2.3 can only be used together with version 3.2 of biblatex. See also the section Make Sure Versions of Biber and biblatex Match in Troubleshooting for biber. – moewe Feb 18 '16 at 7:16
4

Okay, the issue was an outdated biblatex version. According to the Biber doc you need Biblatex v3.2 to work with Biber v2.3. Unless you don't have these versions it's not going to work.

And Biblatex v3.2 creates a .bcf file with the version number 2.9:

<?xml version="1.0" encoding="UTF-8"?>
<bcf:controlfile version="2.9" xmlns:bcf="https://sourceforge.net/projects/biblatex">

Basically I solved my problem by just reinstalling MiKTeX. You can also use the package manager to install the latest packages, but in my case it created just more problems.

|improve this answer|||||
  • 1
    Normally, one would use the MikTeX Updater to make sure all packages are up to date (it comes in an Admin and User version, you run both to be sure everything is fine). See also How should one maintain and update a MiKTeX installation? for details on what to do with critical updates and when to use the Package Manager. A reinstall is rarely the best way to update one's packages. – moewe Feb 18 '16 at 9:48
  • In my case it was the easiest one. :) But, yes you're right of course. You should try to use the package manager properly. – rugk Sep 19 '16 at 12:59
  • @moewe I'm having the same problem as the OP and I've updated everything through the update and package managers, but the problem persists. Actually the problem started after the end of February update. I'll end up reinstalling too. – Massimo Ortolano Mar 4 '17 at 16:51
  • @MassimoOrtolano Are you sure that you have only one version of Biber installed? And that that version of Biber really matches your biblatex version? What errors/warnings do you get exactly? When does the problem occur? With simple documents, or more complicated ones? If the problem persists, please ask a new question with an MWE, a copy of the .blg, the involved package versions and as much information as possible. – moewe Mar 4 '17 at 16:54
  • 2
    @MassimoOrtolano The message is quite clear though. Note that after updating you might have to delete temporary files (especially the .bcf) and recompile. But if that doesn't help, for some reason you are still running biblatex 3.4. Either because even while the package manager shows version 3.7, you haven't actually updated (run the MikTeX Update tool in both Admin and User mode), or you have another installation of biblatex around, try kpsewhich biblatex.sty to see where it is. – moewe Mar 5 '17 at 7:23
3

I have MikTeX 2.9 installed on Windows 10. All packages are updated (in Admin as well as in User mode). When I tried to used Biber I got an error message:

INFO - This is Biber 2.7
INFO - Logfile is 'main.blg'
INFO - Reading 'main.bcf'
ERROR - Error: Found biblatex control file version 2.9, expected version 3.3.
        This means that your biber (2.7) and biblatex () versions are incompatible.
        See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

In package manager the following versions were shown:

  • 2.7 for miktex-biber-bin-x64
  • 3.7 for biblatex

Reinstallation of these packages did not solve the problem.

I checked which biblatex file is used in the system with the following command (open cmd window and simply type this)

kpsewhich biblatex.sty

The output was:

C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/biblatex.sty

Folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/ is basically used to install packages installed "on the fly".

I searched if there are other files biblatex.sty in the system and it turned out that the second copy was stored in the MikTeX installation folder:

c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\

I am not sure what it means. Is it that my MikTeX installation is corrupted or I have double installation of biblatex nor what is the reason for all this.

I made a simple test. I change the folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/ name to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex_old/

and copy the whole folder from c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\ to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/

Next I cleared all generated files in my tex project folder (it is important) i.e. delete *.aux, delete *.bcf, ... etc. and recompiled the project again with pdflatex, next biber, next pdflatex

It works!

|improve this answer|||||
  • +1 I concur with Widz: the problem is related to multiple installations of MikTeX. Before installing a new version of MikTeX, make sure to erase all the previous installations you may have in Roaming and in Local/MikTex. – Denis Cousineau Aug 28 '18 at 1:25
-1
  1. У меня Win10, WinEdt10.2, (MiKTeX 2.9.6500 64-bit), Version 3.14159265-2.6-1.40.18, biber 2.9, biblatex 3.9;
  2. Совместимые версии biber и biblatex: 2.9 3.9; 2.8 3.8; 2.7 3.7; см. инструкцию в YouDisck:..\biblatex\3.10\biblatex\doc\biblatex.pdf, page 6;
  3. Скачал biber.exe v.2.9 (biber-MSWIN64.zip) и заменил biber.exe v.2.7 в C:\MiKTeX\miktex\bin\x64\biber.exe (v.2.7) на новую biber.exe v.2.9. (biber.exe v.2.7 переименовал в =biber.exe v.2.7 для архива).
  4. В MiKTeX Package Manager нашел biblatex (name-->filter) и обновил его до версии 3.9. Можно скачать и установить вручную в C:\localtexmf\tex\latex C:\Users\YouName\AppData\Roaming\MiKTeX\2.9\tex\latex.
  5. Обновил MiKTeX Options Refresh FNDB.

    6. Тестируем любой программой. Всё работает!

  6. I have Win10, WinEdt10.2, (MiKTeX 2.9.6500 64-bit), Version 3.14159265-2.6-1.40.18, biber 2.9, biblatex 3.9;

  7. Compatible versions of biber and biblatex: 2.9 3.9; 2.8 3.8; 2.7 3.7; see the instructions in YouDisck: ..\ biblatex\3.10\ biblatex\ doc\ biblatex.pdf, page 6;
  8. Download biber.exe v.2.9 (biber-MSWIN64.zip) and replace biber.exe v.2.7 in C:\MiKTeX\miktex\bin\x64\biber.exe (v.2.7) with the new biber.exe v .2.9. (biber.exe v.2.7 renamed to = biber.exe v.2.7 for the archive).
  9. In the MiKTeX Package Manager, I found biblatex (name -> filter) and updated it to version 3.9. You can download and install it manually in C:\localtexmf\tex\ latex and C:\Users\YouName\AppData\Roaming\MiKTeX\2.9\tex\latex.
  10. Updated MiKTeX Options Refresh FNDB.
  11. Test any program. Everything is working!
|improve this answer|||||
  • 3
    Welcome to TeX.SE!. Most of links and "steps" provided for solution are in Russian. You might look for the English version or translate them accurately. – Cragfelt Dec 18 '17 at 4:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.