4

I am trying to get gnuplottex running in this MWE:

\documentclass[a4paper, 11pt]{article}
\usepackage[cm]{fullpage}
\usepackage{gnuplottex}

\begin{document}

\begin{figure}%
\centering%
\begin{gnuplot}[terminal=epslatex]
plot sin(x) w l
\end{gnuplot}
\caption{This is a simple example using the epslatex-terminal.}%
\end{figure}%

\end{document}

The figure environment appears, however no plot!

I already included a new typesetting option...

typesetting option

...and the log file says \write18 enabled in the third line.

Nonetheless, the log file says:

This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014/W32TeX) (preloaded format=pdflatex 2014.9.22) 18 FEB 2016 12:01
entering extended mode
\write18 enabled.

[...]

Package gnuplottex Warning: Shell escape not enabled.
(gnuplottex) You'll need to convert the graphs yourself.

[...]

Package gnuplottex Warning: Please convert gnuplot-gnuplottex-fig1.gnuplot manually

[...]

The gnuplot source file is created. I'm using TeX Live 2014, TeXworks, Windows 7 (64bit) and gnuplot 5.0 (path variable is set - gnuplot is launched when typing gnuplot into the console).


EDIT: I'm somewhat confused about how to use the \gnuplotexe in order to directly point to the gnuplot executable...

2

(update after exchanges with OP in comments)

Reading through gnuplottex source, it appears it tests if -shell-escape is enabled via first creating a temporary file. For this it uses unix commands, except under option miktex. I thus suggest to try using that option too, despite the fact you are not under MikTeX. Fingers crossed ...

(notice though that under that option gnuplottex sets to true \ifmiktex boolean, with global scope)


Original answer:

Only to confirm it works with shell-escape enabled. As I am not on Windows I can't help more...

\documentclass[a4paper, 11pt]{article}
\usepackage[cm]{fullpage}
\usepackage{gnuplottex}


\begin{document}

\begin{figure}
\centering
\begin{gnuplot}[terminal=epslatex]
plot sin(x) w l
\end{gnuplot}
\caption{This is a simple example using the epslatex-terminal.}
\end{figure}

\end{document}

Blockquote

  • This is depressing me... :P – LCsa Feb 18 '16 at 12:08
  • hmm... I don't have time now but package gnuplottex has some strange check of its own to test if shell-escape works. Appears to me this is using unix/linux commands which may not work on windows. – user4686 Feb 18 '16 at 12:14
  • I'm sure it works on windows... there is even a miktex option, and this is a pure Windows distribution, if I am right. – LCsa Feb 18 '16 at 12:16
  • 1
    I am on TL2015, but tried TL2014 and it works too. And TL2013 and TL2012 too. I know I am depressing you ;-) Don't despair, surely some Windows expert will see your question. But most are on MikTeX I think. – user4686 Feb 18 '16 at 12:29
  • 1
    ah ok wait I see some \ifmiktex conditionals in gnuplottex. In these branches gnuplottex uses windows command, else unix commands. Have you tried loading it with option [miktex] ? – user4686 Feb 18 '16 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.