3

Sadly, I wasn't able to copy more than just the first of two errors:

! Package unicode-math Error: Cannot be run with pdfLaTeX!
(unicode-math) Use XeLaTeX or LuaLaTeX instead..
See the unicode-math package documentation for explanation.
Type H <return> for immediate help.

Here the full error: Error

I use LaTeX, and as far as I can see, they want me to use XeTeX. I don't know how to improve the CV to LaTeX code.

If you could give me some tips, links etc. in a comment, I would like to try to find a solution and update my question, so that you don't have to do the work all on your own!

  • 3
    the error message seems very clear it is not an error in your file but the command you used. If your cv is cv.tex then you used the command pdflatex cv and you should have used xelatex cv – David Carlisle Feb 18 '16 at 21:42
  • 1
    Hi, XeLaTeX is a modern version of LaTeX and pdfLaTeX. The problem is that the style and class of your CV template cannot be easily 'downgraded'. The document relies on fonts and symbols from the fontawesome package that explicitly needs XeLaTeX. So simply use XeLaTex instead, it is part of your basic texlive/miktex distribution. E.g.: in a terminal type xelatex resume.tex – HATEthePLOT Feb 18 '16 at 21:59
  • Hmmm, strictly speaking you're actually using the pdftex engine to render your document. xetex is a new and improved engine. Both are LaTeX engines, and you can read more about this here and here. XeTeX adds a lot of functionality, such as the ability to use the fonts you're trying to use here, but it'd be unusual for it to break anything else. It takes slightly longer to run, but you can compile all your old files with XeTeX – Au101 Feb 18 '16 at 22:14
  • In short, I really think you're misunderstanding what XeTeX is, it adds a whole load of stuff on top, but it isn't a completely new system or program like LyX might be. You can just switch to running xelatex instead of pdflatex and nine times out of ten you shouldn't notice any difference, but it will enable you to do other things you can't do at the moment. This template you're using requires XeTeX to do everything it's trying to do, so you'll have to use XeTeX, but that's pretty much the only change you'll have to make, you'll still be able to write your code the same way – Au101 Feb 18 '16 at 22:16
4

Well, please read the documentation of this template (please follow your given link).

There you will find:

Usage

At a command prompt, run

$ xelatex {your-cv}.tex

This should result in the creation of {your-cv}.pdf

Conclusion:

This template has to be compiled with XeLaTeX, because it is designed for it ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.