5

Anyone knows how to set the indentation of BibTeX in JabRef? I want it to look like this:So here the = signs are aligned

So here the = signs are aligned

How can I do that in JabRef. I've been playing with the options in JabRef for hours and still have no clue..

===added 21 Feb===

what I mean is mine looks like this:

my Jabref

5
  • 1
    What do you mean ? JabRef always left the equal sings aligned, just go to another reference and return, et voilá, the signs are now aligned.
    – Fran
    Commented Feb 20, 2016 at 6:36
  • My suggestion would be to submit a feature request...
    – Werner
    Commented Feb 20, 2016 at 7:46
  • 2
    They've recently changed the approach to formatting 'raw' entries: this is 'by design' and I'm not sure what if anything is exposed to users. In any case, this looks to me like a feature request (and thus off-topic).
    – Joseph Wright
    Commented Feb 20, 2016 at 8:36
  • If submitting a feature request, please state why you want to have the equal signs globally starting at the same column. The reasoning for starting the { at most far right column at each entry was that each entry looks nice locally and you can do easily copy and pasting end emailing without letting other users think "WTF, what a waste of space". - The current development strategy states that configuration settings are to be removed to improve the overall quality and stability of JabRef.
    – koppor
    Commented Feb 21, 2016 at 21:23
  • Thank you for the comment. It makes sense to keep the format a bit tighter, but it'd be nice if there is an option for the users. But I'm ok with both so no need for a feature request.
    – Hai
    Commented Feb 23, 2016 at 2:02

1 Answer 1

6

In JabRef-2.10 go into Options->Preferences->File->Field Saving options It is in the lower right. Then enable button "Start field contents in same column":

enter image description here

Then you'll get this view and also in the saved bib file:

enter image description here

5
  • 1
    Which JabRef release do you have? I don't see this in v3.2
    – Joseph Wright
    Commented Feb 20, 2016 at 8:42
  • 1
    I have the Ubuntu version 2.10 and I see it is gone in 3.2
    – user2478
    Commented Feb 20, 2016 at 9:05
  • OK, so that matches up with what I thought: this is deliberate
    – Joseph Wright
    Commented Feb 20, 2016 at 9:39
  • 1
    I'm also using 3.2 in Window and I can't see these options. Why would they remove this...
    – Hai
    Commented Feb 21, 2016 at 14:46
  • 2
    A discussion can be read at github.com/JabRef/jabref/issues/116. Please show up at the users mailinglist or comment on the issue.
    – koppor
    Commented Feb 21, 2016 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .