1

I am using Texmaker and Miktex, and having issues to compile the references. In my latex file:

\usepackage[%
backend=biber,%
style=numeric,%
sorting=none,%
]{biblatex}

I am using quick build: pdfLaTeX+View PDF.

When I compile it gets printed linke this: enter image description here

When I compile the same file in ShareLatex it works perfect, so must be some configuration errors.

Do anyone know what the errors are? enter image description here

Running Biber manually returns:

INFO - This is Biber 2.2
INFO - Logfile is 'main.blg'
INFO - Reading 'main.bcf'
WARN - Warning: Found biblatex control file version 2.9, expected version 2.8
INFO - Found 46 citekeys in bib section 0 
INFO - Processing section 0
INFO - Looking for bibtex format file 'citations.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8
INFO - Found BibTeX data source 'citations.bib'
WARN - Duplicate entry key: '7027553' in file 'citations.bib', skipping ...
WARN - Entry ok2006 does not parse correctly
WARN - ISBN '159829556X, 9781598295566' in entry 'Hoelzle' is invalid - run biber with '--validate_datamodel' for details.
WARN - Datamodel: Entry 'oracle' (citations.bib): Invalid format 'n.d' of date field 'date' - ignoring
ERROR - BibTeX subsystem: C:\Users\BILALA~1\AppData\Local\Temp\AI_7lm2bHk\citations.bib_7640.utf8, line 585, syntax error: at end of input, expected one of: name (entry type, key, field, or macro name) or end of entry ("}" or ")")
INFO - WARNINGS: 5
INFO - ERRORS: 1

Process exited with error(s)
  • The line for Bib(la)tex should mention biber not bibtex since you backend is biber. – Bernard Feb 20 '16 at 17:59
  • @Bernard I have tried both, changed to biber now. Still not now working. – user3580316 Feb 20 '16 at 18:02
  • Please see Biblatex with Biber: Configuring my editor to avoid undefined citations: TeXmaker. You will want to use "PdfLaTeX + Bib(La)TeX + PdfLaTeX (x2) + View PDF" for quick build or run Biber manually (probably via F11? or the menu) so that Biber is actually run. "pdfLaTeX+View PDF" alone probably doesn't run the bibliography programme. – moewe Feb 20 '16 at 18:06
  • 1
    The .blg shows quite some problems. Firstly, your versions of biblatex and Biber don't match. Update your distribution before you proceed (see How should one maintain and update a MiKTeX installation?; please note that currently some MikTeX mirrors might be down and might not respond, if you can't make an update don't panic, wait till tomorrow and try again). Also check the other warnings: You seem to have at least two 7027553s, in Hoelzle you should only give one ISBN in the isbn field, ... – moewe Feb 20 '16 at 18:18
  • 1
    .. if you have no date in oracle, so drop the date field ("n.d." can be added automatically), the entry ok2006 does not parse correctly check for missing commas and braces. Then something is not quite right around line 585, check for missing braces there as well. Finally note that you have to run LaTeX after you have run Biber to get to see the bibliography. Normally one runs (in this order) (pdf)LaTeX, Biber, (pdf)LaTeX, (pdf)LaTeX. See also Question mark instead of citation and Troubleshooting for biber. – moewe Feb 20 '16 at 18:20
1

Check if the Default Bibliography Tool is set to txs:///biber If so, run Biber alone from the menu (Tools > Commands > Biber), and then compile it again, should work.

Have you tried to delete the .aux file? Sometimes if it's generated with a bug or something it's faster to remove and re-compile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.