2

I am trying to get around BibTex. I have successfully added the bibliography and everything works. The only problem is that when i have multiple authors, in the bibliography it places "and" before the last one. I need for it to be "i" as its and in Polish. Is there a way to change the language? Or even better, make it not use and before last author. I am using acm style.

  • 4
    Possible duplicate of Bibtex using the wrong language! – jk - Reinstate Monica Feb 23 '16 at 16:52
  • Which bibliography style do you use? – Mico Feb 23 '16 at 17:01
  • 1
    I am using acm. – Bremen Feb 23 '16 at 17:02
  • To the folks who've voted to close this posting,or who are thinking of voting to close: This posting is not a duplicate of the one @jknappen has identified. The earlier posting was about the plain bibliography style. In contrast, the new posting is about the acm bibliography style. – Mico Feb 23 '16 at 17:34
3

It's the bibliography style that tells BibTeX how to format the bibliography. Since you've indicated that you use the acm style -- which, incidentally, hasn't been change meaningfully since 1988 -- I suggest you proceed as follows:

  • Locate the file acm.bst in your TeX distribution. Make a copy of this file and call the copy, say, acm-i.bst. Do not edit an original file of the TeX distribution directly.

  • Open the file acm-i.bst in a text editor; the editor you use to edit your tex files will do fine.

  • Replace all three instances of and " with i ". All three instances of the string and " will be preceded by lines that contain et~al. as a substring.

  • Save the file acm-i.bst, either to the directory that contains your main tex file or to a directory that's searched by BibTeX. If you choose the latter option, be sure to update the filename database of your TeX distribution.

  • In your main tex file, replace the instruction \bibliographystyle{acm} with \bibliographystyle{acm-i}, and re-run LaTeX, BibTeX, and LaTeX twice more to fully propagate all changes.

Happy BibTeXing!

  • This is exactly what I needed, thank you. Since you know your way around BibTex, maybe you could help me with one more thing? I figured out how to change the edition field to math my requirements, I cannot however handle 2 more things: How to remove the coma after surnames (before name 1st letters)? And second, how to make authors list finish with colon after the dot? I managed to make colon appear before the ending dot only... I would apreciate all help! – Bremen Feb 23 '16 at 22:27
  • 1
    @ŁukaszPrzeniosło - On the issue of omitting the comma between the surnames and the first initials: On line 196 of acm-i.bst, change the string "{vv~}{ll}{, jj}{, f.}" to "{vv~}{ll}{, jj}{ f.}". On the second issue: I'm afraid I'm not exactly sure what you're looking to achieve. Please post a new question, in which you explain in more detail what the formatting objective is. – Mico Feb 24 '16 at 2:06
  • @ŁukaszPrzeniosło - Just saw your earlier posting again, about formatted entries having to look like [1] Doe J.: How to format bibliography?. JohnDoe limited, Warsaw, 2015. Speaking for myself, I find several of the embedded stylistic settings -- e.g., .: at the end of the author field and ?. at the end of the title field -- nothing short of dreadful. If you really must implement these settings, I suggest you do so by editing the .bbl file (which is produced by BibTeX) hand and modifying the contents of the \bibitems to make them conform to the requirements you must satisfy. – Mico Feb 24 '16 at 14:59
  • I could actually do that- edit the output file. But I am also kind of trying to understand how does the bibtex code syntax work, so I can change things in the future. As for now, it is very confusing for me. All I got left to figure out is only the .: at the end of authors list. Thank you for help. – Bremen Feb 24 '16 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.