6

I get unnecessary and weird hyphenation along with orphaned words at the end of my paragraphs although there is plenty enough room to fit the word into the line before. Some times, they aren't even complete words, just syllables in the last line of my paragraph. That can't be right, right?

Is there a way to force latex to always use to smallest spacing possible?

My current setup is:

\documentclass[fontsize=12pt,bibliography=totoc,listof=totoc,parskip=half*,
        captions=tableheading,BCOR=7mm,english,numbers=noenddot,twoside=true,
        headsepline=true]{scrbook}    
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel} 

along with other packages, that should not concern the spacing or hyphenation. My output looks like:

Example Text

Is this a known problem?

edit: the input text is

The new common language will be more simple and regular than the existing European languages.

The new common language will be more simple and regular than the existing European languages. It will be as simple as Occidental; in fact, it will be Occidental. 

The new common language will be more simple and regular than the existing European languages. It will be as simple as Occidental; in fact, it will be Occidental too.

The new common language will be more simple and regular than the existing European languages. It will be as simple as Occidental; in fact, it will be Occidental too three.

The new common language will be more simple and regular than the existing European languages. It will be as simple as Occidental; in fact, it will be Occidental too three four.
  • Can you prove your statement "there is plenty enough room to fit the word into the line before"? You should know that TeX manages the setting of content on a paragraph basis, not on a line-by-line basis. – Werner Feb 23 '16 at 20:33
  • please fix the code example so that it produces the output shown, then people can easily test any answers. – David Carlisle Feb 23 '16 at 20:43
  • latex has quite a high default penalty set for hyphenating the penultimate line of a paragraph so basically it will only do it if there is no choice. Presumably it could not squeeze tal on to the line above without compressing the white space more than the (user-settable) limits. – David Carlisle Feb 23 '16 at 20:46
  • @Werner The image shows an example. In the third paragraph the same text fitted although is was broken into three lines in the previous paragraphs. – Bjorn Feb 23 '16 at 20:58
  • @DavidCarlisle But in the second and third paragraph, the 'tal' fits into the line. – Bjorn Feb 23 '16 at 21:00
5

Use

parskip=half-,

instead of half*. Read the documentation of KOMA-Script on page 71 for the difference.

The manner consists of two elements. The first element is either full or half, meaning the space amount of one line or only half of a line. The second element is “*”, “+”, or “-”, and may be omitted. Without the second element the last line of a paragraph will end with white space of at least 1 em. With the plus character as second element the white space amount will be a third, and with the asterisk a fourth, of the width of a normal line. The minus variant does not take care about the white space at the end of the last line of a paragraph.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.