3

I want to have a twoside document, left pages should be aligned more to the left and right pages more to the right. Also, when I begin a chapter this should always begin on the right side. All the pages before introduction should have roman numbering, and the pages after the contents should have arabic numbering.

Thus, Chapter one should start at page number 1, at the right hand side of the document, with an increased left margin. I figured the latex book style should cope with this quite easily, below is a minimal working example.

\documentclass[a4paper,twopage]{book}
\usepackage[english]{babel}
\usepackage{blindtext}

\frontmatter
\begin{document}

\begin{titlepage}
    \blindtext
\end{titlepage}

\begin{titlepage}
    \blindtext
\end{titlepage}

\chapter*{abstract}
\blindtext[6]

\mainmatter

\chapter{introduction}
\blindtext[6]

\end{document}

minimal example

The problems are:

  • The titlepage is the first page, and should start with an increased left margin, however, it starts with an increased right margin.
  • The abstract is the first chapter, and thus it should start on the right side, with an increased left margin, this is also not true. Same goes for the introduction.

I tried the options openright, openleft, and openany, all three have no effect.

How to solve?

edit: Added the frontmatter and mainmatter. Still no effect.

  • Have you tried to put \frontmatter just before \begin{document} and \mainmatter just before the first chapter ? – Jérôme Dequeker Feb 24 '16 at 16:31
  • Yes, this solves the page numbering. – InteressantPunt Feb 25 '16 at 12:12
2

As Jérôme Dequeker suggests in the comments, try \frontmatter and \mainmatter for the page numbering. For the margins, use e.g. the geometry package. You can easily set the inner and outer page margins. When you are satisfied with the page setup, you can drop the showframe option. I have also changed the openright \documentclass option to twopage. See the code below.

\documentclass[a4paper,twopage]{book}
\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage[showframe, inner=4cm, outer=2cm]{geometry}

\begin{document}

\frontmatter

    \begin{titlepage}
        \blindtext
    \end{titlepage}

    \begin{titlepage}
        \blindtext
    \end{titlepage}

    \chapter*{abstract}
    \blindtext[6]

\mainmatter

    \chapter{introduction}
    \blindtext[6]

\end{document}

Edit:

The book class in default adds a so-called "margin note" box to the outer edge (you can type into the margin note box e.g. by the standard \marginpar command). That is, in fact, what you see when not using the geometry package (which I assume sets it to zero). The twopage option sets the outer and inner margins as you would expect. See the example below. Here, I have used the showframe package to show the margins without resetting them.

\documentclass[a4paper,twopage]{book}
\usepackage[english]{babel}
\usepackage{blindtext}
%\usepackage[showframe, inner=4cm, outer=2cm]{geometry}
\usepackage{showframe}

    \begin{document}

        \frontmatter

        \begin{titlepage}
            \blindtext
        \end{titlepage}

        \begin{titlepage}
            \blindtext
        \end{titlepage}

        \chapter*{abstract}
        \blindtext[6]

        \mainmatter

        \chapter{introduction}
        \blindtext[1]
        \marginpar{\textbf{This is a margin note:} \blindtext[1]}

        \blindtext[2]

        \blindtext[3]
    \end{document}

enter image description here

| improve this answer | |
  • 1
    This makes the chapters start at the right side, however, the margins are not the same as without the geometry package. Basically the geometry package forces the margins in the right way, but they dont have the same distance as before. Still not what I am looking for – InteressantPunt Feb 25 '16 at 8:20
  • I have added some explanation of the phenomena you are seeing. See the updated answer. – Ondrian Feb 25 '16 at 11:18
  • Ah yes. I figured the margins are there for binding purposes. So a wider margin corresponds to the side closest to the bind. – InteressantPunt Feb 25 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.