1

I am using Latex trough TeXnicCenter with core of MikTeX...in this week news I've found something about tree graphs and I wanted to try it by myself but when I used appropriate code (copied from the code on the page) MikTeX tried to install forest package automatically but it got stucked with error: pdflatex> ! LaTex Error: File 'elocalloc.sty' not found ...I've read "Not so short introduction to Latex2" but I am no expert... maybe it would be enough to instal this one manually but I am not sure where to download it and how to do it...

  • synchronize the package database. tex.stackexchange.com/a/108490/2388 – Ulrike Fischer Feb 25 '16 at 21:25
  • I did it, but now it has different problems (38 errors), but maybe it wasn't done properly :/ – Jozef Janočko Feb 25 '16 at 21:48
  • You need to update your installation of TeX generally. You have an outdated LaTeX base which is responsible for that error. The number of errors you get is pretty much completely useless information. What is the first one? Please also post the exact minimal document you are trying to compile. Telling us it is the code you copied from some unknown page of something unknown is really not helpful. – cfr Feb 25 '16 at 22:34
  • I used code from here (first answer) tex.stackexchange.com/questions/295330/… And first error: pdflatex> ! Package xparse error: support package 13kernel too old \\ So maybe you are right and I have old version of Tex in general... so you suggest to upload MikTeX? Because it would want to do some critical updates (according to tex.stackexchange.com/questions/108447/… ) and I cannot risk that MikTeX stop working... I am using it for writing master thesis :( – Jozef Janočko Feb 26 '16 at 10:14
  • Since you have some responses below that seem to answer your question, please consider marking one of them as ‘Accepted’ by clicking on the tickmark below their vote count (see How do you accept an answer?). This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). It's part of this site's idea to identify good questions and answers through upvotes and acceptance of answers. – user36296 Aug 24 '16 at 14:09
1

Launch MiKTeX Package Manager, wait until it displays the list of packages, select forest , right-click on it and choose install. The error message says you need to install elocalloc:

enter image description here

  • Thx, I tried, but it was showing that it is already instaled, even though it does not work. I tried to uninstal it and than instal it again... but after while of working it showed no progress for a long time so I closed the instalation window...Then I tried it again but it showed basicaly the same errors. – Jozef Janočko Feb 26 '16 at 10:18
  • Also install the elocalloc package, as the error message says. – Bernard Feb 26 '16 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.