2

I'm relatively new with LaTeX and I can't find the solution to a problem I came through only recently.

I'm using TeXLive 2015 with the editor TeXstudio, which I updated to the most recent version (2.10.8) a couple days ago, after a while I was using the version 2.10.0.
My problem is that the documentation search that is accessible by right-clicking to a package name is not working anymore, since the following message is showing up:

texdoc did not respond to query on package: babel

The search worked perfectly with the previous version I had. Moreover, texdoc works when I launch it through the command window: i.e. writing the command line

texdoc babel

opens the documentation as expected.

Searching a bit through the Web led me to some questions about the same problem (you can read it here and here), but I can't figure out how the solution works. I assume some modifications must be done to the TeXstudio configuration, and I tried to add the texdoc folder path to the TeXstudio commands as it is suggested, but I must have failed something, since this had no effect.

Where am I wrong?

EDIT: I uninstalled and reinstalled TeXstudio, but the problem still remains.
I forgot to specify I am using Windows 10.

  • I am using the same TeXStudio version and the documentation for Babel works fine. So, I guess it's not a software bug. If it works in the command line, then you don't have the path problem. The links you said are more targeting the search path parameters. – Winsoft Feb 26 '16 at 12:29
  • @Winsoft : thank you for commenting. Just to be clear, the malfunctioning regards every package documentation, not only babel's. Maybe something went wrong with the installation... I'll try to reinstall TeXstudio. – 19lorenz88 Feb 26 '16 at 13:07
  • Please see here if you get some fix or reopen, if you think it is a bug with Windows 10: sourceforge.net/p/texstudio/bugs/1193 and sourceforge.net/p/texstudio/discussion/907840/thread/1b641019 – LaRiFaRi Mar 2 '16 at 15:17
  • same here: I'm guessing you have a space in the path? texdoc gui and texstudio don't seem to like that. – naphaneal Mar 21 '16 at 21:10
  • @LaRiFaRi : thank you for your input and sorry for the late reply. Those are the same discussions I skimmed through while I was searching for a solution some time ago, but I never figured out how to make it work because I couldn't find the Additional Search Paths -> Commands ($PATH) line in Config. I always overlooked the advanced options. Now I added the folder in which texdoc is located and everything works fine! – 19lorenz88 Apr 6 '16 at 8:15
1

I solved the problem following the discussions provided at this link. The Additional Search Paths -> Commands ($PATH) is under Advanced options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.