2

I'm using TeXlive 2015 on Ubuntu 14.04. I have a file that looks like this:

\documentclass{article}
\usepackage{academicons}
\begin{document}
\aiicon{orcid}
\end{document}

When I do $ latexmk -xelatex foo I get the following error:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! ! ! fontspec error: "font-not-found" ! ! The font "academicons" cannot be found. ! ! See the fontspec documentation for further information. ! ! For immediate help type H . !...............................................

I thought it would help to install the Academicons .ttf, but it didn't. Does anybody know why xelatex can't find the font?

Here is the log:

Latexmk: applying rule 'pdflatex'...
This is XeTeX, Version 3.14159265-2.6-0.99992 (TeX Live 2015) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
(./foo.tex
LaTeX2e <2015/10/01> patch level 2
Babel <3.9n> and hyphenation patterns for 79 languages loaded.
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2015/texmf-dist/tex/latex/academicons/academicons.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/expl3.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/expl3-code.tex)
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/l3xdvipdfmx.def))
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3packages/xparse/xparse.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec-patches.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec-xetex.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/euenc/eu1enc.def)
(/usr/local/texlive/2015/texmf-dist/tex/latex/euenc/eu1lmr.fd))
(/usr/local/texlive/2015/texmf-dist/tex/xelatex/xunicode/xunicode.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/tipa/t3enc.def
(/usr/local/texlive/2015/texmf-dist/tex/latex/euenc/eu1lmss.fd))
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/latexconfig/graphics.cfg)
(/usr/local/texlive/2015/texmf-dist/tex/xelatex/xetex-def/xetex.def
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)))))
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec.cfg)))

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! fontspec error: "font-not-found"
! 
! The font "academicons" cannot be found.
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H <return>.
!...............................................  

l.12 \newfontfamily{\AI}{academicons}

? 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! fontspec error: "font-not-found"
! 
! The font "academicons" cannot be found.
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H <return>.
!...............................................  

l.12 \newfontfamily{\AI}{academicons}

? 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! fontspec error: "font-not-found"
! 
! The font "academicons" cannot be found.
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H <return>.
!...............................................  

l.12 \newfontfamily{\AI}{academicons}

? ) (./foo.aux) (/usr/local/texlive/2015/texmf-dist/tex/latex/tipa/t3cmr.fd)
! Font EU1/academicons(0)/m/n/10=academicons: at 10.0pt not loadable: Metric (T
FM) file or installed font not found.
<to be read again> 
                   relax 
l.4 \aiicon{orcid}

? [1] (./foo.aux) )
Output written on foo.pdf (1 page).
Transcript written on foo.log.
Latexmk: Errors, so I did not complete making targets

closed as off-topic by cfr, Andrew, Jesse, Zarko, Paul Gaborit Feb 28 '16 at 6:54

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You shouldn't have to install anything extra. The font is included already. Your minimal example compiles fine for me. However, I have a system set-up which includes the relevant font directory in fontconfig's configuration. Run without latexmk to rule out complications there. What's your OS? What does kpsewhich academicons.ttf give? If you are on a suitable system, what does fc-match Academicons give? – cfr Feb 27 '16 at 21:45
  • I'm using Ubuntu 14.04.kpsewhich academicons.ttf gives me '/usr/local/texlive/2015/texmf-dist/fonts/truetype/public/academicons/academicons.ttf'. fc-match Academicons gives 'academicons.ttf: "Academicons" "Regular"'. – twsh Feb 27 '16 at 21:51
  • Can you post the log from your minimal example up to the error? It shouldn't be too long. – cfr Feb 27 '16 at 21:54
  • 1
    That's strange. Are you using the most recent version (2016/01/14 v1.6 ) of academicons? Because as I already wrote in my answer, in the most recent version the font is loaded using \newfontfamily{\AI}{Academicons} (pay attention to the capital A). – Benjamin Feb 27 '16 at 23:24
  • 4
    I'm voting to close this question as off-topic because the problem was due to an outdated package and has been fixed by upgrading to the latest TeX Live. (See comments.) – cfr Feb 28 '16 at 4:26
1

EDIT:

As of version 1.6-1 the manual states, that it is recommended to install the academicons font on the system. So as @dfernan stated in the comments the behavior, that XeLaTeX cannot find the font if it is not installed on the system, is not a bug but by design.


In my opinion this is a bug in the package. The package tries to load the font, saved in the texmf-dist/fonts folder by its font name like this:

\newfontfamily{\AI}{Academicons}

That does only work for LuaTeX. Have a look at this Question for more information. So instead the package should load the font using

\newfontfamily{\AI}{academicons.ttf}

to work for XeLaTeX and LuaTeX out of the box.

But installing the font on your system should actually solve the font loading problem. I don't have a Linux system at hand right now, but if I remember correctly you have to update your fontconfig caches after a font installation? Did you do that?

  • 1
    As is clear from the comments, the font is already recognised by fontconfig. – cfr Feb 27 '16 at 21:53
  • 1
    This is not a bug in the package. \newfontfamily{\AI}{Academicons} loads the font from the system, which requires installing it. Because there may be differences between the package and previous or newest font versions, it is recommended to have the bundled version installed. The OP had mismatched versions of the package and the font, which caused the issue. I am the academicons package maintainer. – dfernan Mar 2 '16 at 16:27
  • @dfernan Ok if that is intended, it is not a bug. But then you should update the manual. You write in the manual: "This package requires the fontspec package and either the XƎ(LA)TEX or Lua(LA)TEX engine to load the included academicons.ttf font." This implies, that it is not necessary to install the font. – Benjamin Mar 2 '16 at 16:33
  • @Benjamin, I did just that while posting the comment here and uploaded a new package noting that. Thanks for the comment. – dfernan Mar 2 '16 at 17:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.