7

I am using XeLaTeX.

\documentclass[10pt,twoside]{report}

\usepackage[thresholdtype=words]{csquotes}
\usepackage{enumerate}

\begin{document}

    \blockquote{
        \textbf{konungr} (-s, -ar), \textit{m.}
        \begin{enumerate}
            \item king.
        \end{enumerate}
    }

\end{document}

which produces the following error:

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...

l.13 ^^I}

However, if I remove the package option for csquotes, i.e. replace line 3:

\usepackage[thresholdtype=words]{csquotes}

with this:

\usepackage{csquotes}

It compiles fine. The result looks like:

the result

which is properly indented.

This is a minimally compiling example. I do not want to remove that package option because I want to have a similarly indented \blockquote for a very short line that follows this. Without the package option, this:

\documentclass[10pt,twoside]{report}

\usepackage{csquotes}
\usepackage{enumerate}

\begin{document}

    \blockquote{
        \textbf{konungr} (-s, -ar), \textit{m.}
        \begin{enumerate}
            \item king.
        \end{enumerate}
    }

    \blockquote{
        Nouns like ``konungr'' \textit{king} and ``dvergr'' \textit{ghost} decline in the easiest pattern.
    }

\end{document}

the result is:

enter image description here

The second \blockquote does not get indented like the first one, but instead gets enclosed by double quotes.

  • 1
    Interesting problem. But does \blockquote even make sense? If you have an enumerated list, won't it always be a proper block quote? I'd think the \begin{displayquote} (in csquote language) or \begin{quote} environment would be the natural choice. – jon Mar 1 '16 at 1:41
  • @jon Thank you. I replaced \blockquote with \begin{displayquote} and now it works regardless of whether the package option is specified or not. But I would still like to know why the errors occur in my situation explained in the question. – hello all Mar 1 '16 at 2:04
3

I assume the problem is due to how csquotes counts words, but I'm in no position to explain the gory details. However, you can work around the problem.

My first thought is that quotations which include lists should simply be put in csquotes' displayquote environment. That is,

\begin{displayquote}
  \textbf{konungr} (-s, -ar), \textit{m.}
    \begin{itemize}
        \item king.
    \end{itemize}
\end{displayquote}

Alternatively, you could create your own version of \blockquote, which switches from counting by words back to the default line-counting. The example below is merely proof of concept and provides a far 'dumber' \blockquote-type command than the original. (But maybe that's no real loss: I hever bother with the optional arguments myself.)

\documentclass[10pt,twoside]{report}

\usepackage[thresholdtype=words]{csquotes}
\SetBlockThreshold{50}
%\usepackage{enumitem}% this package does not affect problem

\newcommand\zzz[1]{%
  \begingroup
  \setkeys{csq}{thresholdtype=lines}%
  \blockquote{#1}%
  \endgroup
}

\newcommand{\example}{This is a minimally compiling example. I do not
  want to remove that package option because I want to have a
  similarly indented blockquote for a very short line that follows
  this.  This is a minimally compiling example. I do not want to
  remove that package option because I want to have a similarly
  indented blockquote for a very short line that follows this.}

\begin{document}

\example

\blockquote{This is a minimally compiling example.}

\blockquote{\example}

    \zzz{%
        \textbf{konungr} (-s, -ar), \textit{m.}
        \begin{itemize}
            \item king.
            \item or: ``rex''
        \end{itemize}
    }

\blockquote{\example}

\example

\blockquote{This is a minimally compiling example.}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.