1
\documentclass[12pt,a4paper,oldfontcommands,oneside]{memoir}

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhf{}
\lhead{\leftmark}

\begin{document}

\listoftables
\clearpage

\chapter*{List of Symbols}
\addcontentsline{toc}{chapter}{List of Symbols}

My list of symbols is already two pages long. The problem: on the second page header it does not say "List of Symbols" but "List of Tables". If I use \chapter instead of \chapter* the chapter will be numbered eventhough it shouldn't be numbered. Any ideas on how to manually change the "current chapter" for fancyhdr on this single page?

0

I'd advise against using fancyhdr with the memoir document class, as the class already provides a similar functionality to updating the headers/footers.

In order to obtain the appropriate header for your List of Symbols, use

\chapter*[List of Symbols]{List of Symbols}

The optional argument for \chapter also changes the header (or chapter mark).

  • Thanks, it works. I'm writing a thesis and, for some reason, i chose the memoir class. However, with my current code the report class produces too many errors so I will stick with the memoir. For the PhD thesis I will probably switch then. – Relam Mar 1 '16 at 17:07
  • @Relam: Yes, your minimal code shows you're using memoir, so I provided a solution based on that. The default report class does not offer the option of using a \chapter* with an optional argument. You can only use \chapter[..]{...} or \chapter*{...}, but not \chapter*[..]{...}. – Werner Mar 1 '16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.