4

I have page number for some first few pages in roman style (\pagenumbering{roman}) and the rest arabic (\pagenumber{arabic}).

Now it need to position them such that:

  • page number should be 3/4 of an inch from the bottom edge of the page.
  • they should be flush with the right page margin.

I've tried

\usepackage{fancyhdr}
\rfoot{\thepage}

but page numbers position in the middle of bottom page. Also, I don't know how to change the position of page number with respect to bottom of the page.

Can someone please help?

Thanks,

2
\documentclass[12pt,titlepage]{report}
\usepackage[
  top    = 1in,
  bottom = 0.75in,
  left   = 1.25in,
  right  = 1.25in,
  headsep=5mm,%%% Example
  includeheadfoot,%%%%%%%%%%%%%%%%%%%%%%%%%%
  showframe]{geometry}
\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhf{}% clearsall
\fancyhead[RE,LO]{\normalsize foo}
\rfoot{\thepage}
\usepackage{blindtext}
\begin{document}

\blinddocument

\end{document}
  • You need to add a \thispagestyle{fancy} to the first page of each chapter, or redefine pagestyle plain to be fancy. (\let\ps@plain=\ps@fancy) – John Kormylo Mar 1 '16 at 15:45
  • no, I do not need that. I always use plain on chapter pages. – user2478 Mar 1 '16 at 16:19
  • hmm, I got some page numbers flushed to the right correctly, but then some pages have the page numbers in the middle. really weird. Can't find what causes this. – chepukha Mar 1 '16 at 18:41
  • btw, here's the variation I used. – chepukha Mar 1 '16 at 18:49
  • 1
    Delete the lines \textheight=.. and \textwidth=.. That should all be done by the settings of geometry – user2478 Mar 2 '16 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.