3

so I'm having precisely the issue described here:

https://sourceforge.net/p/texshop/bugs/87/

I'm using TeXShop 3.58 on a Macbook pro running El Capitain.

Roughly speaking, I'm working on my thesis (currently 80+ pages), and every time I retex my document the memory used (according to Activity Monitor) increases slightly. TeXShop is currently using 11.19 GB (10.54GB of compressed memory). Historically once it gets past 18-20GB or so I get a warning message saying that my computer has run out of application memory, and forces me to force quit certain apps. Quitting texshop fixes this (temporarily), and reopening it reduces its memory footprint to under 1gb at first.

I've tried the suggestion given in the link above (using the command "defaults write TeXShop ReleaseDocumentClasses 0" in the Terminal), but it didn't seem to do anything.

The link above is however 9 years hold now, so I was wondering if there has been any additional progress on this front.

closed as off-topic by egreg, user13907, Jesse, Svend Tveskæg, Mensch Mar 1 '16 at 23:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – egreg, Community, Jesse, Svend Tveskæg, Mensch
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Welcome! Have you tried asking the developer about this? – cfr Mar 1 '16 at 21:49
  • @cfr I haven't. I suppose I could try that. I haven't used any other editors. – oxeimon Mar 1 '16 at 21:49
  • Well, if closing TS fixes it temporarily, then TS certainly appears to be a suspect. And if TS does have a memory leak then the only person who can do anything about it is the developer. I'm not, to be honest, certain what kind of answer could be given here. 1G sounds like a huge amount of memory for a text editor to take, never mind 11G. – cfr Mar 2 '16 at 0:36
  • That bug is very old. I thought the memory leak problem could not be fixed on versions of OS X prior to 10.5, but should not manifest on later versions. I don't think that bug had anything to do with TS but something to do with Quartz rendering. (But it is a long time ago and I might be misremembering the details.) I remember this because my laptop could not comfortably run any version on which the bug was fixed (or maybe couldn't run it at all). Apple had no interest in fixing the bug on my machine. Needless to say, that was my last Mac. – cfr Mar 2 '16 at 0:42

Browse other questions tagged or ask your own question.