0

When using the monochrome option for xcolor in a Beamer presentation, the canvas background shows up as entirely black when compiling with pdflatex, but would be entirely white if compiled with xelatex. (I'm using MacTeX 2015):

\documentclass[xcolor={monochrome}]{beamer}
\begin{document}
\begin{frame}
Hello World!
\end{frame}
\end{document}

What's causing the different behavior? Is there any way to get the background white when using monochrome, at least when the canvas background is left as the default?

  • Can you try with Adobe Reader if you have it by any chance? – percusse Mar 2 '16 at 10:08
  • @percusse I tried opening the pdflatex output with Preview, Skim and Adobe Reader DC (all on Mac OSX El Capitan), the frame is still gloriously black. – LianTze Lim Mar 2 '16 at 14:01
0

Actually the default background canvas of a beamer presentation is not transparent but filled with the normal text background color, as it is defined as

\setbeamercolor{background canvas}{parent=normal text}

in beamercolorthemedefault.sty. So what you could do is to actually make it transparent by setting

\setbeamercolor{background canvas}{bg=}

Edit:

Or you could use the xcolor option gray instead of monochrome, which seems to be working the same with pdfLaTeX and XeLaTeX.

  • Ah thanks -- no idea how I had the impression that it's transparent; I've now edited my question. But this still doesn't quite explain the different behavior between xelatex and pdflatex, right? – LianTze Lim Mar 2 '16 at 14:02
  • 1
    @LianTzeLim You are right it doesn't explain the different behavior. As far as I understand it, xelatex is in the wrong here, as the monochrome option should set all colors to black hence also white. If you want a grayscale output you should use the option gray. Also test this example with xelatex: \documentclass{article} \usepackage[monochrome]{xcolor} \begin{document} \color{blue}Test \end{document} This does also not work as it should. – Benjamin Mar 2 '16 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.