4

i built my CV half a year ago and everything worked fine back then. Now that I am trying to recompile it, it seems to have simply broken down and I cant tell why... The most minimal not working version I managed to brake it into (without deleting too much hopefully) is this:

\documentclass[12pt,a4paper]{moderncv}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{romannum}
\usepackage{lmodern}
\usepackage[german]{babel}
\usepackage{palatino}

\moderncvtheme[blue]{classic}               

\usepackage[scale=0.84]{geometry}
\setlength{\hintscolumnwidth}{2.8cm}    
\AtBeginDocument{\setlength{\maketitlenamewidth}{6cm}}
\AtBeginDocument{\recomputelengths} 

% personal data
\name{z}{o}
\title{Curriculum Vitae}
\address{A}{i}
\mobile{98978}        
\email{blabla@test.de}

\photo[100pt]{img/profil}       

\begin{document}
\maketitle
\end{document}

The errors are.

 Undefined control sequence. \begin{document}
Missing number, treated as zero. \begin{document}
Illegal unit of measure (pt inserted). \begin{document}
You have requested package `moderncvheadi', but the package provides `moderncvheadi'.
You have requested package `moderncvbodyi', but the package provides `moderncvbodyi'.
Underfull \hbox (badness 10000) in paragraph

I am using Win 7 with miktex. I have tried updating all available packages so far and reinstalling moderncv, but nothing helps. As I said, this has already worked a few months ago...

Anybody know how to deal with this?

Regards, Michael

4

The length maketitlenamewidth doesn't seem to exist anymore. So remove the line:

\AtBeginDocument{\setlength{\maketitlenamewidth}{6cm}}
  • that indeed was the problem...thanks for making the effort! – Michael A Mar 3 '16 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.