1

I am not sure why the margin on the right side of my document is unusually larger than usual. I am presenting an MWE where I have (unsuccessfully) tried to resolve the issue:

\documentclass[a4paper,11pt]{article}
%\usepackage[utf8]{inputenc}
%\usepackage[T1]{fontenc}
%\usepackage[latin9]{inputenc}
\usepackage{amsthm}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{mathtools}
\usepackage{cite}
\usepackage{enumerate}
\usepackage[colorlinks=true,
            linkcolor=red,
            urlcolor=blue,
            citecolor=gray]{hyperref}
\usepackage{xcolor,listings}
\usepackage{url}
\usepackage[english]{babel}
\usepackage{blindtext}
\newcommand{\todo}[1]{\textcolor{red}{[#1]}}
\oddsidemargin 0in
\evensidemargin 0in
\title{Assignment1}
\author{Joe Schmoe}
\date{}
\begin{document}

\maketitle

\section*{Question 1}
\blindtext
\end{document}
1
  • Well, you used \oddsidemargin=1in. You should not manipulate those settings directly. Use \usepackage{geometry} with appropiate settings. Off-topic here: hyperref should be the last package to be loaded.
    – user31729
    Mar 4 '16 at 23:30
1

With the oneside default option in article, \evensidemargin is never considered. Contrary to what you may think, it doesn't set the right margin, but only states what's the left margin on even numbered pages when the printing is twoside.

By saying \oddsidemargin=0in, you're telling LaTeX that the text starts one inch from the left border of the page. Yes, really! Such parameters are best dealt with by experienced users. Note that you're not setting \textwidth so the default value is used.

You don't tell what your aim is, but if it is to have one inch on either margin, it's much simpler to call geometry:

\usepackage[
  left=1in,
  right=1in,
]{geometry}

Remove the settings to \oddsidemargin and \evensidemargin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.