I just started to use Zotero in Overleaf. When I tried to cite a wiki page, I got an error:

Missing $ inserted.
<inserted text> 
l.3 \bibitem[_wi, 2016]{_wikipedia:user_2016}

When I check Zotero.bib, I saw that the record starts an underscore, which causes the problem (I tried to manually remove and it solves the problem).

    title = {Wikipedia:{User} pages},
    copyright = {Creative Commons Attribution-ShareAlike License},
    shorttitle = {Wikipedia},
    abstract = {Abstract},
    language = {en},
    urldate = {2016-03-05TZ},
    journal = {Wikipedia, the free encyclopedia},
    month = feb,
    year = {2016},
    note = {Page Version ID: 707348267}

How to prevent this problem? Because, doing this manually is not manageable for a larger scale project.

Thank you very much, Adam

  • (Adds this to the list of reasons to just use the BibTeX format directly…) Is there any reason it might add the underscore? Is there an underscore in the record online? Could a name conflict have arisen between this and any other record? Mar 5, 2016 at 16:29

1 Answer 1


This is a known issue on the Zotero side: https://github.com/zotero/translators/issues/771. I'm not sure if Overleaf allows you to modify the Zotero bibtex export it uses -- if so, fixing this in the javascript is pretty easy (or, more easily still, you can use the better bibtex add-on. Otherwise you'd have to wait until someone finally gets around to fixing this in Zotero proper. (The underscore gets added because of a missing author, btw. Not that that's a good reason.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .