2

As per the Title. I am trying to use \mathspec so that I can override the default math font.

When I typeset, I am told that the various Greek letters (Gamma, Delta, etc.) have already been defined. I can hit return 11 times to get through them, but that's probably not best way to deal with it...

MWE:

\documentclass{article}
\usepackage{amsmath}
\usepackage[math]{mathspec}
\defaultfontfeatures{Mapping=tex-text}
\setmathsfont(Digits,Latin,Greek){Asana Math}
\setprimaryfont[Mapping=tex-text]{Palatino}
\setallsansfonts[Scale=MatchLowercase,Mapping=tex-text]{Optima}
\setallmonofonts[Scale=MatchLowercase]{Fira Mono}


\begin{document}
Here's my test: $ \chi^2 + 27 $.
\end{document}
  • If I change the fonts to ones I have, then I get the same error but the error goes if I remove the [math] option, do you need that? (In general it's probably recommended to use unicode-math rather than mathspec these days.) – David Carlisle Mar 6 '16 at 18:52
  • The [math] option loads fontspec without the no-math option. I don't think you should. – egreg Mar 6 '16 at 20:33
  • Hmm, I must have misunderstood the mathspec option: [math]. I thought without that, it was using fontspec without math. It now runs for me as well and I haven't noticed any missing characters. – Pwdr Mar 7 '16 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.