1

This question already has an answer here:

After I did an update of MikTeX of packages lualatex won't compile anymore.

I tried this solution Why does Lualatex crash after a recent update?, but no luck.

I got this error file:

Creating the lualatex format file...
Running miktex-luatex.exe...
This is LuaTeX, Version beta-0.80.0 (MiKTeX 2.9) (rev 5238)  (INITEX)

restricted \write18 enabled.

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/latexconfig/lualatex.ini"

(D:/Users/yannie.NET/AppData/Roaming/MiKTeX/2.9/tex/generic/config/pdftexconfig

.tex) ("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/latex.ltx"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/00miktex/texsys.cfg")

./texsys.aux found

\@currdir set to: ./.


Assuming \openin and \input 

have the same search path.


Defining UNIX/DOS style filename parser.

catcodes, registers, compatibility for TeX 2,  parameters,

LaTeX2e <2016/02/01>

hacks, control, par, spacing, files, font encodings, lengths,

====================================



Local config file fonttext.cfg used



====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/00miktex/fonttext.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fonttext.ltx"

=== Don't modify this file, use a .cfg file instead ===



("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omlenc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/t1enc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1enc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omsenc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/t1cmr.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmr.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmss.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmtt.fd")))

====================================



Local config file fontmath.cfg used



====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/00miktex/fontmath.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fontmath.ltx"

=== Don't modify this file, use a .cfg file instead ===



("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omlcmm.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omscmsy.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omxcmex.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ucmr.fd")))

====================================



 Local config file preload.cfg used



=====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/preload.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/preload.ltx")) page nos.,

x-ref, environments, center, verbatim, math definitions, boxes, title,

sectioning, contents, floats, footnotes, index, bibliography, output,

======================================================================

starting package maintenance...

installation directory: D:\Users\yannie.NET\AppData\Roaming\MiKTeX\2.9

package repository: http://ctan.uib.no/systems/win32/miktex/tm/packages/

lightweight database digest: 2a55def48ddd605f3ac84361a931f865



Unfortunately, the package unicode-data could not be installed.Please check       the log file:

D:/Users/yannie.NET/AppData/Local/MiKTeX/2.9/miktex/log/miktex-luatex.log

======================================================================



 Unicode character data,



! LaTeX Error: File `load-unicode-data.tex' not found.



Type X to quit or <RETURN> to proceed,

or enter new name. (Default extension: tex)



Enter file name: 

! Emergency stop.

<read *> 



l.8167   \input{load-unicode-data}




 190 words of node memory still in use:

   nodes

  avail lists: 2:11,3:1

 !  ==> Fatal error occurred, no output PDF file produced!

 Transcript written on lualatex.log.


 Sorry, but miktex-makefmt did not succeed for the following reason:

 miktex-luatex.exe failed on lualatex.ini.

The log file hopefully contains the information to get MiKTeX going again:

D:/Users/yannie.NET/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log

You may want to visit the MiKTeX project page, if you need help.

Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

D:/Users/yannie.NET/AppData/Local/MiKTeX/2.9/miktex/log/initexmf.log

You may want to visit the MiKTeX project page, if you need help.

Attached you can find the log for lulatex

2016-03-07 17:07:25,426+0100 INFO  miktex-luatex - installing package     unicode-data triggered by tex\generic\unicode-data\UnicodeData.txt
2016-03-07 17:07:25,569+0100 INFO  miktex-luatex - mpm: starting package     maintenance...
2016-03-07 17:07:25,569+0100 INFO  miktex-luatex - mpm: installation directory: D:\Users\yannie.NET\AppData\Roaming\MiKTeX\2.9
2016-03-07 17:07:25,569+0100 INFO  miktex-luatex - mpm: package repository: http://ctan.uib.no/systems/win32/miktex/tm/packages/
2016-03-07 17:07:25,695+0100 INFO  miktex-luatex - mpm: lightweight database digest: 2a55def48ddd605f3ac84361a931f865
2016-03-07 17:07:25,700+0100 FATAL miktex-luatex - Unknown archive file size.
2016-03-07 17:07:25,700+0100 FATAL miktex-luatex - Info: package="unicode-data"
2016-03-07 17:07:25,700+0100 FATAL miktex-luatex - Source: libraries\miktex\packagemanager\internal.h
2016-03-07 17:07:25,700+0100 FATAL miktex-luatex - Line: 497

Now I cannot compile my tex files. I use Lualatex because it uses dynamic memory for my pgfplots (a lot of data)

marked as duplicate by Martin Schröder, user13907, Mensch, barbara beeton, Zarko Mar 8 '16 at 3:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    miktex tried to install the unicode-data package but the installation failed due to the "unknown archive file size". Try to install it with the package manager from another repository. – Ulrike Fischer Mar 7 '16 at 16:26
  • @UlrikeFischer thanks for the answer. Tried that and did not get the error while doing the Build in the MikTEX. I tried compiling a document in TexStudio and got an error about the package ctablestack not found. I proceeded to install this and later I got tons of error referring to fontspec and hobsub-generic.sty. Any idea now? – Gabriel Mar 7 '16 at 17:21
  • 1
  • Great! It seems to work again! The last link did the trick. I had just updated the Admin. Thanks again @UlrikeFischer, I will keep you updated of something else pop up – Gabriel Mar 7 '16 at 18:56

Browse other questions tagged or ask your own question.