1

Using TexStudio 2.10.8 on MacOSX 10.11.3 with language-tool installed.

I am trying to get the "bad words" highlighting of TexStudio to work. Therefore I created a list of bad-words badwords/bad_words.tex, with one word per line (line separated).

bad_words.txt contents:

also
eigentlich
sprich
...

I setup TexStudio to look in the folder badwords: TexStudio settings snippet with "Check for Bad Words" enabled and path set up

TexStudio should recognize eigentlich, also and super from my bad_words.tex list, but it does not recognize any of the bad words used in this sentence:Sentence containing three words from my list of bad-words

Any ideas?

  • Did you get a solution for the bad words checking? Because a new user (albflo) of this page is stuck with the same problem! The bad words work perfectly for myself with TeXstudio 2.11.0 on Win7. Maybe it is just linked to MacOSX? – LaRiFaRi Sep 6 '16 at 14:44
  • Actually I have not checked this for a while. Will do so, when I get back to the macos workstation next week. – Florian Z. Sep 7 '16 at 9:20
3

TeXstudio should provide you already with a file called

de.badWords

which should have been installed to a subfolder.

utilities/de.badWords

Otherwise: goto

Applications/TeXstudio/<right click and> Show Package Contents

and see if the file is installed in one of the subfolders.

or perform:

locate de.badWords

in a Terminal

You might also see this for additional clues:

Dictionary for TeXstudio: “No dictionary Available”

  • I looked for the included badWords files and found them, but I still get no highlighting. I then double checked that "check for bad words" is activated and that the highlighting is set up accordingly. Btw. does it work on your system? – Florian Z. Mar 14 '16 at 10:02
  • @FlorianZ.: I try to avoid so called "Weichspülerworte" (bad words) therefore I have no clue if it works on my system. The checkbox is activated though. – naphaneal Mar 14 '16 at 10:12
  • In syntaxhighlighting section in the config-menu bad words are supposed to marked stricken in some purple color. But that seem to have no effect. – naphaneal Mar 14 '16 at 12:13
2

The bad words file must be named after the current language/dictionary. If you use "de_DE" then use "de_DE.badWords"

For me I had "de_DE_frami" so it did not pick up the "de_DE.badWords"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.