2

I updated MikTex 2.9 Monday, and now can't compile while loading 'mhchem'. I'm using pdflatex [Version 3.14159265-2.6-1.40.16 (MiKTeX 2.9 64-bit)] to compile the following:

\documentclass{article}
\usepackage[version=4]{mhchem}
\begin{document}
Hello, world!
\end{document}

throws the following error:

! LaTeX error: "kernel/command-not-defined"

! Control sequence \prop_get:Nn undefined.

! See the LaTeX3 documentation for further information.

! For immediate help type H <return>.

l.180 ..._variant:Nn \prop_get:Nn           { cV }

| This is a coding error.

| LaTeX has been asked to use a control sequence '\prop_get:Nn': this has not been defined yet.
3
  • It runs without error in texlive updated just now. add \listfiles to the preamble and post the resulting list from the end of the log file. Mar 8, 2016 at 16:25
  • Can't compile, throws 100 errors, so the file list is not shown!
    – TobiasDK
    Mar 8, 2016 at 16:31
  • This is the log file: db.tt/1GGf9vFa
    – TobiasDK
    Mar 8, 2016 at 16:33

1 Answer 1

4

You have a local old copy of chemgreek masking your installed one:

(C:\Users\TobiasGram\AppData\Roaming\MiKTeX\2.9\tex\latex\chemgreek\chemgreek.sty

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

("C:\Program Files\MiKTeX 2.9\tex\latex\l3packages\xparse\xparse.sty"
Package: xparse 2016/01/19 v6377 L3 Experimental document command parser
\l__xparse_current_arg_int=\count170
\l__xparse_m_args_int=\count171
\l__xparse_mandatory_args_int=\count172
\l__xparse_processor_int=\count173
\l__xparse_v_nesting_int=\count174
)
Package: chemgreek 2015/04/09 v1.0 interface for upright greek letters for use in chemistry (CN)

It should be more like

(/usr/local/texlive/2015/texmf-dist/tex/latex/chemgreek/chemgreek.sty
(/home/davidc/texmf/tex/latex/l3packages/xparse/xparse.sty
Package: xparse 2016/01/19 v6377 L3 Experimental document command parser
\l__xparse_current_arg_int=\count170
\l__xparse_m_args_int=\count171
\l__xparse_mandatory_args_int=\count172
\l__xparse_processor_int=\count173
\l__xparse_v_nesting_int=\count174
)
Package: chemgreek 2016/02/10 v1.0e interfaceforuprightgreeklettersforuseinchem
istry (CN)
6
  • I don't use miktex but I gather from other answers seen here that it has user and admin installations and you need to update both, probably. Mar 8, 2016 at 16:41
  • If I just delete it, should that be okay, and then update it again?
    – TobiasDK
    Mar 8, 2016 at 16:42
  • I don't know how miktex's package manager reacts to deleting things by hand, just updating your installation under Users\TobiasGram\AppData\Roaming should be enough, or wait for someone who's used miktex to pass by and confirm:-) Mar 8, 2016 at 16:55
  • I uninstalled 'chemgreek' from Packages Manager, and deleted the 'chemgreek folder in AppData, and reinstalled 'chemgreek' again. Then Refresh FNDB and Update Formats in Settings. Working now :-) Thank you for the help David!
    – TobiasDK
    Mar 8, 2016 at 17:20
  • If the chemgreek packages is vers. 1.0d, then one need to do a manuel install from CTAN: mirrors.ctan.org/macros/latex/contrib/chemgreek.zip
    – TobiasDK
    Mar 11, 2016 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.