14

As of today, I have not been able to build any documents using the biblatex-chicago class. MWE follows:

\documentclass{article}
\usepackage[nopar]{lipsum} % for dummy text
\usepackage[american]{babel}
\usepackage[babel]{csquotes}
\usepackage[backend=biber]{biblatex-chicago}
\begin{filecontents}{\jobname.bib}
@book{Saussure1995,
Author = {Ferdinand de Saussure},
Origyear = {1916},
Publisher = {Payot},
Title = {Cours de Linguistique G{\'e}n{\'e}rale},
Year = {1995}}

\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}

\lipsum[1]\autocite{Saussure1995}    

\end{document}

Running latexmk -cd -e -f -pdf -interaction=nonstopmode -synctex=1 myfile.tex

produces the following error:

 Undefined control sequence.
\cms@choose ->\ifblx@load@version@one 
                                      nty\else cms\fi 
l.40 \begin{document}

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

The MWE works without problems if I substitute biblatex for biblatex-chicago.

Any ideas? Thank you.

6
  • This compiles fine for me on a TL 2015 system. Have you deleted all your aux files and tried again? What happens when you run the pieces separately, i,e., run pdflatex then biber then pdflatex? – Alan Munn Mar 10 '16 at 23:12
  • Deleting all temp files (including .aux) does not resolve the issue. Running manually breaks at step one (pdflatex), with the same error message. – BorromeanNot Mar 10 '16 at 23:21
  • It seems due to the new biblatex version. :( – egreg Mar 10 '16 at 23:25
  • @egreg Yes, I just updated and now it fails for me too. – Alan Munn Mar 10 '16 at 23:31
  • 1
    Please be aware that the new biblatex version has changed the name formatting commands in a way that will cause no errors with biblatex-chicago, but some name definitions will be ignored silently. Do check your output for CMS compliance. – moewe Mar 16 '16 at 10:26
4

The biblatex-chicago package has been updated to version 0.9.9h 2016-03-22.

According to the package documentation, this update specifically addresses incompatibilities with biblatex, version 3.3.

The biblatex-chicago package is now available through CTAN: http://www.ctan.org/pkg/biblatex-chicago

15

This is caused by a change in the biblatex test for an old system. The previous conditional was called \ifblx@load@version@one and is used in the biblatex-chicago style. The new conditional is called \ifblx@load@version@legacy. You can temporarily solve the problem in the following way by adding the following to your preamble, after loading biblatex.

\makeatletter
\def\cms@choose{cms}
\makeatother

A more general solution is given in Herbert's answer:

\makeatletter
\let\ifblx@load@version@one\ifblx@load@version@legacy
\makeatother

But a long term solution to the problem will be a fix to biblatex-chicago.

0
10

Write into the preamble:

\usepackage{biblatex-chicago}
\makeatletter
\let\ifblx@load@version@one\ifblx@load@version@legacy
\makeatother

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.