I'm a newbie… and have started using TexMaker recently. I use it pretty sporadically (so I'm no expert). I found the following error while trying to install the package mathtools: LaTeX Error: File `mathtools.sty' not found.

I don't have anything else (like MiKTeX etc) on my machine. Any suggestions on how to resolve this? If getting MiKTeX is the only way to do this, will I need to un-install TexMaker, install MiKTeX and then re-install TexMaker?

  • if you get a latex error you must have tex installed (miktex or texlive most likely) you would not get that error from texmaker (which is just the editor) Commented Mar 11, 2016 at 22:17
  • How did you try to install a package if you don't have a distribution?
    – Bernard
    Commented Mar 11, 2016 at 22:23
  • well - I just ended up typoing \usepackage{amsmath} for example and it worked fine. Issue happened ONLY with mathtools package.
    – Chet
    Commented Mar 14, 2016 at 13:53

2 Answers 2


If you have installed MikTeX, TexLive or MacTex, your question is answered here or here. If not, you need to install TeXLive or MacTeX.

I think your problem is that you haven't installed LaTeX but just an editor.

You have to install LaTeX. There are different solutions how to install LaTeX, depending on which operating system you use.


Open an editor (Strg+Alt+T). Type following in:

sudo apt-get update
sudo apt-get install texlive-full

You can also download TexLive for Linux on your own:

wget ftp://ftp.mpi-sb.mpg.de/pub/tex/mirror/ftp.dante.de/pub/tex/systems/texlive/Images/texlive2015-20150523.iso
sudo mount -o loop texlive2015-20150523.iso /mnt
cd /mnt
sudo ./install-tl


Download TexLive here and just install it the usual way.


Install MacTeX from here.

That should fix your problem. Your problem is, that you haven't installed the libraries for LaTeX, not installed LaTeX at all. You have just installed an editor, a user interface that helps you editing and writing LaTeX code. But you have nothing that compiles your code to a PDF.

  • Thanks Amabile. Everything (writing the code and converting it to PDF using the embeded viewer) has worked fine till I tried to use mathtools. Today, I installed MikeTex and everything has stopped working....So I'll try to uninstall and reinstall TexMaker as per one of the suggestions above.
    – Chet
    Commented Mar 14, 2016 at 13:56

If you're using Windows on your computer, then the most common distribution would be MiKTeX.

TeXmaker is only the frontend in which you write. Once MiKTeX is installed you have to configure all paths to every command in the config-menu of TeXmaker.

I recommend to uninstall and reinstall TeXmaker instead, which is faster.

  • I'd suppose TeXstudio reads the paths from the registry…
    – Bernard
    Commented Mar 11, 2016 at 23:31
  • @Bernard you are indeed correct. it is only a hassle iff you had customized commands.
    – naphaneal
    Commented Mar 12, 2016 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .