6

I guess I have a kinda specific questions. I'm writing my bachelor report using LaTeX using the scrreport class, and I want the pages before the first chapter to have roman page numbers. Beginning with the first page after the list of figures (which is the last page before the first chapter), I want to have arabic page numbers. Those should start with 1.

My structure is like this (the numbers are the page numbering I want):


Abstract I

Table of contents II

List of figures III

  1. Chapter One 1

  2. Chapter Two 8

...


That's also how I want the Table of Contents (TOC) to look like.

Currently I added \pagenumbering{roman} and \pagenumbering{arabic}. This solved the part of having the pages numbered right, but there are a few problems:

  1. I don't want the abstract to be the first chapter, so I declared it with \chapter*{abstract}. This way it does not show up in the table of contents. Also Chapter one starts with page two in the table of contents, despite it having page one at the bottom. If I remove the * from the abtract-chapter-declaration, it shows up in the TOC, but it's handled like the first chapter which I do not like.
  2. TOC and List of Figures (LOF) also do not show up in the TOC. Can I somehow add them? I guess they do not show up because they are not declared in chapters but simply with the commands \tableofcontents and \listoffigures.

Edit:

Hey guys, thanks for the fast responses and comments! I did some more digging and found out how to solve my problems. I added the three parts missing in the TOC (the TOC itself, the list of figures and the abstract-chapter) manually, using \addcontentsline{toc}{chapter}{Abstract} at the end of the abstract-chapter and

\cleardoublepage
\phantomsection
\addcontentsline{toc}{chapter}{\contentsname}
\tableofcontents

instead of plain \tableofcontents (same for list of figures) It also somehow fixed the problem of Chapter One starting with page 2 despite being on page 1. I have no idea what fixed it, maybe the use of \cleardoublepage?

  • 1
    Welcome to TeX.SE! The statement Beginning with the first page after the table of content[s], I want to have arabic page numbers seems to be in conflict with the statement that you want the list of figures to be on a Roman-numbered page. Please clarify. – Mico Mar 12 '16 at 12:10
  • 1
    Thanks for the welcome! You're right, I forgot about the list of figures in the first draft. I edited my post and hope that everything's clear now. – Jdv Mar 12 '16 at 12:15
  • 1
    Add \cleardoublepage before \pagenumbering{arabic} – egreg Mar 12 '16 at 12:20
  • Can you please provide a Minimal Working Example (MWE)? Here's a suggestion on how to realize it meta.tex.stackexchange.com/a/3350/177 – Alessandro Cuttin Mar 12 '16 at 12:22
  • Welcome, add \setuptoc{toc}{totoc} as seen in texwelt.de/wissen/fragen/4035/… – Johannes_B Mar 12 '16 at 12:31
4

Use \addchap{Abstract} to get an unnumbered chapter with an entry in TOC.

\documentclass[
  listof=totoc% lists in TOC
]{scrreprt}
\setuptoc{toc}{totoc}% TOC in TOC
\usepackage{blindtext}% dummy text
\begin{document}
\pagenumbering{Roman}
\addchap{Abstract}
\tableofcontents
\listoffigures
\cleardoubleoddpage
\pagenumbering{arabic}
\blinddocument
\end{document}

enter image description here

2

If you're free to switch from the scrreprt to the scrbook document class, you could make use of \frontmatter and \mainmatter directives of the latter class to simplify matters. For instance, by using the \frontmatter directive, chapter-level entries won't be numbered but will still show up in the table of contents.

Issue the directive \setuptoc{toc}{totoc} and specify the document class option listof=totoc to have entries for the table of contents and the list of figures show up in the table of contents itself.

To mimic some of the layout settings of the scrreprt class, you could specify the document class option oneside and issue the directive \pagestyle{plain} (to suppress running headers).

enter image description here

\documentclass[oneside,listof=totoc]{scrbook}
\setuptoc{toc}{totoc}
\pagestyle{plain}   % no running headers
\usepackage{lipsum} % filler text

\begin{document}

\frontmatter
\pagenumbering{Roman}  % default is "roman", not "Roman"

\chapter{Abstract}
\lipsum[1]

\tableofcontents
\listoffigures

\mainmatter % (i) page break, (ii) change page numbering style to "arabic"

\chapter{Chapter One}
\begin{figure}[h!] \caption{abc} \end{figure}
\lipsum[1-35]

\chapter{Chapter Two}
\lipsum[1-4]
\end{document} 
  • please no tocbibind with KOMA-script. listof=totoc an the one mentioned in the comments above. – Johannes_B Mar 12 '16 at 12:31
  • @Johannes_B - Thanks, will make the appropriate edits. – Mico Mar 12 '16 at 12:33
  • One more thing: If the table of contents header must be "Table of Contents" rather than just "Contents", issue the instruction \renewcommand\contentsname{Table of Contents} in the preamble. – Mico Mar 12 '16 at 12:44
  • 1
    Or \renewcaptionname{ngerman,german}{\contentsname}{Inhaltsliste} if the language is set up properly. – Johannes_B Mar 12 '16 at 12:46
  • @Johannes_B - Thanks. I was basing my comment on what the OP wrote (about "Table of Contents"). :-) – Mico Mar 12 '16 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.