1

When I run imakeidx with \usepackage[truexindy]{imakeidx} I get the following error:

sh: truexindy: command not found.

Not sure what is going here.

This is with an up to date TL2015 on OSX.

  • Indeed, there is no truexindy program; if you use the truexindy option, you should know how to directly call xindy with the necessary options. Possibly the warning is misleading, but xindy is the program to launch. – egreg Mar 15 '16 at 7:44
  • Sorry, I still don't get it. The xindy option already makes LaTeX fail. Whatever I define in the program option is simply ignored. – Simifilm Mar 15 '16 at 7:57
2

Possibly the documentation is not really clear, but the correct usage of the truexindy option is as value of program:

\documentclass{article}
\usepackage{imakeidx}

\makeindex[
  program=truexindy,
  options= -C utf8 -M texindy -L english,
]

\begin{document}

X\index{X}

\printindex

\end{document}

You should know what options you want to pass to xindy.

This is the relevant part of the log, after running pdflatex -shell-escape simifilm.tex:

This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex 2016.2.27)  15 MAR 2016 19:04
entering extended mode
 \write18 enabled.
 %&-line parsing enabled.
**simifilm
(./simifilm.tex
LaTeX2e <2016/02/01>
Babel <3.9q> and hyphenation patterns for 81 language(s) loaded.
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/size10.clo
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
(/usr/local/texlive/2015/texmf-dist/tex/latex/imakeidx/imakeidx.sty
Package: imakeidx 2013/07/11 v1.3a Package for typesetting indices in a synchro
nous mode

[...]

\simifilm@idxfile=\write3
\openout3 = `simifilm.idx'.


Writing index file simifilm.idx
No file simifilm.aux.
\openout1 = `simifilm.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 9.
LaTeX Font Info:    ... okay on input line 9.
[1

{/usr/local/texlive/2015/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
runsystem(xindy -C utf8 -M texindy -L english simifilm.idx)...executed.


(./simifilm.ind) [2

] (./simifilm.aux) ) 
Here is how much of TeX's memory you used:
 8005 strings out of 493033
 156764 string characters out of 6134139
 175299 words of memory out of 5000000
 11567 multiletter control sequences out of 15000+600000
 4553 words of font info for 17 fonts, out of 8000000 for 9000
 1141 hyphenation exceptions out of 8191
 41i,4n,44p,10430b,275s stack positions out of 5000i,500n,10000p,200000b,80000s
</usr/local/texlive/2015/texmf-dist/fonts/type1/public/amsf
onts/cm/cmbx10.pfb></usr/local/texlive/2015/texmf-dist/fonts/type1/public/amsfo
nts/cm/cmbx12.pfb></usr/local/texlive/2015/texmf-dist/fonts/type1/public/amsfon
ts/cm/cmr10.pfb>
Output written on simifilm.pdf (2 pages, 25008 bytes).
PDF statistics:
 23 PDF objects out of 1000 (max. 8388607)
 15 compressed objects within 1 object stream
 0 named destinations out of 1000 (max. 500000)
 1 words of extra memory for PDF output out of 10000 (max. 10000000)

The messages on the console about xindy are

Opening logfile "/dev/null" (done)
Reading indexstyle...
Loading module "/var/folders/8b/hx9v58ln1txgzv4v32_vpbr40000gn/T/zObxVZbCmD"...
Loading module "lang/english/utf8-lang.xdy"...
Loading module "lang/english/utf8.xdy"...
Finished loading module "lang/english/utf8.xdy".
Finished loading module "lang/english/utf8-lang.xdy".
Loading module "texindy.xdy"...
Loading module "numeric-sort.xdy"...
Finished loading module "numeric-sort.xdy".
Loading module "latex.xdy"...
Loading module "tex.xdy"...
Finished loading module "tex.xdy".
Finished loading module "latex.xdy".
Loading module "latex-loc-fmts.xdy"...
Finished loading module "latex-loc-fmts.xdy".
Loading module "makeindex.xdy"...
Finished loading module "makeindex.xdy".
Loading module "latin-lettergroups.xdy"...
Finished loading module "latin-lettergroups.xdy".
Finished loading module "texindy.xdy".
Finished loading module "/var/folders/8b/hx9v58ln1txgzv4v32_vpbr40000gn/T/zObxVZbCmD".
Finished reading indexstyle.
Finalizing indexstyle... (done)

Reading raw-index "/var/folders/8b/hx9v58ln1txgzv4v32_vpbr40000gn/T/vIfQlONOYA"...
Finished reading raw-index.

Processing index... [10%] [20%] [30%] [40%] [50%] [60%] [70%] [80%] [90%] [100%]
Finished processing index.

Writing markup... [10%] [20%] [30%] [40%] [50%] [60%] [70%] [80%] [90%] [100%]
Markup written into file "./simifilm.ind".

This shows the run is successful and, indeed, I get the expected result.

  • Then I get Package imakeidx Warning: Remember to run (pdf)latex again after calling (imakeidx) xindy -C utf8 -M texindy -L english xindy.idx. Is that actually the point? If so, the documentation is really not clear. Why can the package call texindy but not'xindy? – Simifilm Mar 15 '16 at 17:20
  • @Simifilm You have to run with shell escape enabled, if you want automatic run of xindy. The program should be called truexindy in the option because of an unfortunate oversight in the first version. – egreg Mar 15 '16 at 17:29
  • I have shell escape enabled and the automatic run does indeed work with texindy. But it doesn't work with your MWE. I get the message I posted. The only way I can make your example work, is by putting a symbolic link to xindy called texindy into texbin. – Simifilm Mar 15 '16 at 17:50
  • @Simifilm I added the relevant parts of the logs. I have no problem. – egreg Mar 15 '16 at 18:09
  • Ok, I have to apologize. It does work. It was a combination of things which lead to it not working. Sorry again. But the documentation could definitely be improved. – Simifilm Mar 15 '16 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.