4

I started using TeXstudio and it seems it doesn't recognize the "[" key on my keyboard.

I have a Croatian keybard layout, so "[" sign is AltGr+F.

Strange thing is that it recognizes all the other keys alright, so I can use "]" (AltGr+H), "č", "đ"...

Anyone has any experiences with this behaviour ?

4
  • you might want to check how shortcuts are set up in TeXstudio and see if ALT+F corresponds to any of them.
    – naphaneal
    Commented Mar 14, 2016 at 11:01
  • Hi, thanks for help. I tried to find the Alt+F shortcut in the shortcuts, but I didn't find anything tied to Alt+F. And when I click this combination nothing happens. It is as if nothing is tied to it.
    – krumpir
    Commented Mar 14, 2016 at 11:12
  • 2
    see if the workaround in this post helps: sourceforge.net/p/texstudio/feature-requests/268/#4a79
    – naphaneal
    Commented Mar 14, 2016 at 12:17
  • @krumpir It might also help to edit in your operating system: I'm guessing it's either Windows or some flavour of Linux, but it would help to be sure (especially if Naphaneal's link doesn't solve it for you).
    – Dɑvïd
    Commented Mar 14, 2016 at 12:23

2 Answers 2

4

Some of TXS standard shortcuts contain Ctrl+Alt (e.g. Ctrl+Alt+S - Save As...). Accidentially windows treats AltGr like Ctrl+Alt. Therefore, you wouldn't be able to type AltGr+S, which is a certain character e.g. on a Polish keyboard, but instead you would trigger "Save As...". Since there are only a few such cases and it's limited to windows, we do not want to disregard Ctrl+Alt shortcuts completely.

Instead, we've included a list of exceptions. Known problematic shortcuts will be changed or deactivated on startup based on the current keyboard language. If you experience problems with certain characters, please report them so that we can add them to the exclude list. As a workaround, you can also change the corresponding shortcut in the options.

From TeXstudio FAQ: I cannot type certain characters on my keyboard that involve AltGr on windows.

1
  • 1
    Could you make this post more self-contained so people don't have to click-through in order to find their solution?
    – Werner
    Commented Mar 15, 2016 at 22:21
4

As described in the feature request linked by @naphaneal, you should change one of the default shortcuts in TeXstudio.

Suggested by xyris, the person who brought up the issue:

To remove the shortcut:

  1. Go to Options > Configure TeXstudio.
  2. Under "Shortcuts" find the command Menus > Idefix > Go To > Definition. You will see in the third column that its "Default Shortcut" is Ctrl+Alt+F, as well as in the fourth column its "Current Shortcut".
  3. In the fourth column "Current Shortcut" double click on the text "Ctrl+Alt+F" and a drop down list will open.
  4. Scroll all the way to the top and select "" or <none> and close the window with OK.
1
  • Works perfectly!
    – domotorp
    Commented Jan 18, 2023 at 9:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .