20

I'm writing a submission for an ACM conference, using the ACM's acm_proc_article-sp document class. Now, this is a document I transitioned from another document class, so the LaTeX in the body of this paper is pretty sound. Still, I'm getting error message:

> ! Argument of \MT@res@a has an
> extra }.

In a place with no funny business taking place (no figures, no equations, just text and section/subsection/etc headers.)

What could be triggering this?

Edit: I can no longer reproduce this myself, but this is an issue, as we can tell from the comments. If you read this question when encountering the same problem yourself - please ask a new question, even if it's somewhat of a dupe, since this one is closed. And - try harder than I did to post a Minimal Reproducible Example.

21
  • 2
    You are a member for over 4 years, have asked 59 questions yourself and answered almost the same amount of answers. You should know that it is impossible to help with the error message. And by the way, the comment is completely fine for What could be triggering this?
    – Johannes_B
    Mar 14, 2016 at 12:15
  • 6
    the error message hints at a problem related to microtype, but without an example impossible to solve
    – Robert
    Mar 14, 2016 at 23:48
  • 4
    I started getting this message when I started using the Cormorant Garamond font with XeLaTeX and redefining titles via titlesec. I had still loaded microtype so disabling it resolved the problem as suggested @Robert's comment. But it also was resolved by either changing the font back to default or by disabling titlesec. I was trying to figure out how to reproduce the problem but have been unable to so far. But maybe my observations help someone in the future.
    – jan
    Oct 20, 2016 at 6:37
  • 4
    I get this error in the ACM template if I include \{ in the email command. E.g.: \email{\{foo\}}. I have not yet found a solution.
    – Max
    Jun 21, 2017 at 14:10
  • 1
    @innisfree: Then, perhaps you could try minimizing the document manifesting the issue, and filing a bug report with the microtype maintainer(s)? If you do so, please post an answer here. Of course, for me, this was a few years ago by now...
    – einpoklum
    Oct 2, 2020 at 7:35

1 Answer 1

5

This might be a problem with special characters (e.g. accents) in your .bib file. My problem was solved thanks to this comment, which suggested simply adding \usepackage[T1]{fontenc} to the preamble of the .tex document.

2
  • 1
    I can no longer reproduce the issue - after 4 years I don't have those files the way I had them then - but I hope this helps others who may encounter the same error. So, not voting, but thanks.
    – einpoklum
    Oct 6, 2020 at 9:51
  • This did not work for me, but in my case I had a ³ in a URL in my bibliography, which I converted to a regular 3 and thankfully the URL still worked. In addition, this was not an issue when using scrreport, but only when using the journal's official template for some reason. Jul 12, 2022 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .