4

As I am using KOMA it ist recommended to use the package scrlayer-scrpage instead of fancy.

Unfortunately I am encountering some problems: I am using scrbook, and the head and footer shoul look like:

  • Head separation line
  • on the left page - header: section
  • on the right page - header: chapter, BUT without "chapter" at the beginning (only the number)
  • on every page - footer: pagenumber

That's my code I am actually using:

\usepackage[headsepline]{scrlayer-scrpage}
\setlength{\headheight}{1.1\baselineskip}

In combination with:

\automark[section]{chapter}
\clearpairofpagestyles
\ihead{}
\ohead[\headmark]{\headmark}
\ifoot{}
\ofoot[\pagemark]{\pagemark}
\renewcommand*{\chapterpagestyle}{empty}

But there are some bugs now I can't figure out myself:

  • the pagenumber is missing on the new page of a chapter (with and without number)
  • the chapter displayed in the header is not without "chapter" at the beginning
  • After the TOC I have created a nomenclature with acronym. Unfortunately the header still is named Table of contents. How do I tell latex to change that the chapter has changed?

Thanks a lot for your help!

6

Remove the line \renewcommand*{\chapterpagestyle}{empty} from your code. Then the page style on chapter pages will be plain. To get no header entries on plain pages remove the optional argument of \ohead.

I guess that option chapterprefix is used in your document. To remove "chapter" from the header redefine \chaptermarkformat

\renewcommand*\chaptermarkformat{\thechapter\autodot\enskip}

enter image description here

enter image description here

Regarding your third question: Maybe you have to use \addchap{Acronyms}. If that does not help please ask a separat question with a MWE (minimal working example) that shows the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.