0

Minimum not working example:

\documentclass[12pt]{article}

\usepackage{newtxtext,newtxmath} % Times New Roman
\usepackage{tikz}
\usepackage{pgfplots}
\usepackage{hyperref} % clickable links
\usepackage{float} % for fixed floats (H)
\usepackage{subcaption} % figures side-by-side
\usepackage[margin=1.0in]{geometry} % nice margins
\usepackage{booktabs} % midrule etc
\usepackage{microtype} % better justification; always use with pdflatex!
\usepackage{siunitx} % for scientific notation AND units!

\begin{document}
test
\end{document}

Log says:

...
! You can't use a prefix with `\begingroup'.
<to be read again>
\begingroup
l.14 \begin{document}
I'll pretend you didn't say \long or \outer or \global or \protected.
Normal \count register pool exhausted, switching to extended pool.
...

This occurs with pdflatex version Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian) but doesn't occur with Version 3.14159265-2.6-1.40.16 (MiKTeX 2.9 64-bit)

What could be the problem?

  • Could you post the entire log. Besides, that is an old latex and miktex 2.9 must be assumed to the never – daleif Mar 15 '16 at 19:06
  • @daleif The entire log is too long to post, the relevant part should be there – eimrek Mar 15 '16 at 19:58
  • that was a bug in etex.sty if you do not want to update the packages try adding \usepackage{etex} as early as possible. – David Carlisle Mar 15 '16 at 20:19
  • @DavidCarlisle unfortunately, I already tried that, it didn't fix it. Also the I forgot to mention that the error disappears when I leave out any one of the listed packages – eimrek Mar 15 '16 at 20:26
  • 1
    I noticed commenting \usepackage{float} removes error. So, then I tried adding \usepackage{floatflt} along with \usepackage{float}, now the document is error free for me. – Sunilkumar KS Mar 16 '16 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.