2

I'm encountering problems with biblatex (Biber as backend).

When defernumbers=true is specified references show all as [0] (style=numeric-comp) both in the text and in the numbering of the bibliography section. Without the option references are printed normally but of course numbering in the text follows the order in the bibliography.

TexLive is updated and I'm using TexStudio.

Complete call of package:

\usepackage[style=numeric-comp,
defernumbers=true,
firstinits=true,
hyperref,
useprefix,
backref,
url=false,
isbn=false,
backend=biber]{biblatex}

Edit: I'm using latest version of biblatex and biber. I run pdflatex then biber then pdflatex 2 times. Now the result do not change despite defernumbers is 'true' or 'false' as the order is alphabetical and not following citing order in the text.

Here the short example:

\documentclass[]{article}

\usepackage{filecontents}

\begin{filecontents*}{123.bib}
@book{Aaa2001,
    author = {Aaa, A.},
    year = {2001},
    title = {The \TeX book 1},
}
@book{Bbb2002,
    author = {Bbb, B.},
    year = {2002},
    title = {The \TeX book 2},
}
@book{Ccc2003,
    author = {Ccc, C.},
    year = {2003},
    title = {The \TeX book 3},
}
@book{Ddd2004,
    author = {Ddd, D.},
    year = {2004},
    title = {The \TeX book 4},
}
\end{filecontents*}

\usepackage[style=numeric-comp,
defernumbers=true,
firstinits=true,
hyperref,
useprefix,
backref,
url=false,
isbn=false,
backend=biber]{biblatex}

\addbibresource{123.bib}

\begin{document}

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua \cite{Bbb2002}.

Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat \cite{Ddd2004}.

Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.



\nocite{*}
\printbibliography

\end{document}
  • 1
    Welcome to TeX.SX! Unfortunately, we cannot really diagnose your problem without a full, yet short example document that shows the issue. (Have a look at this help on MWEs) I can imagine this happening because of some refcontext/refsection interactions, but that is just a guess. – moewe Mar 16 '16 at 15:36
  • Usually that means you haven't run latex a second time - defernumbers always needs an extra run to read the .aux file, as mentioned in the manual. If you are still having issues, tell us the version of biblatex you are using. – PLK Mar 16 '16 at 17:17
  • The MWE does not show the problem from the title for me. Do you maybe just want sorting=none, to get sorting by appearance in the text? (You might have to delete the .aux, .bcf, .bbl files for this setting to become effective.) – moewe Mar 17 '16 at 7:18
  • 1
    sorting=none solved the problem, i don't know how but didn't find this command. Thanks! you save my day! – Mav223 Mar 17 '16 at 8:29

Browse other questions tagged or ask your own question.