2

I get some errors trying to use the animate package with the cprotect or/and bigfoot packages.

When I use the cprotect package in:

\documentclass[10pt, oneside, openany]{book}
\usepackage{graphicx}
% \usepackage{bigfoot} 
\usepackage{cprotect}
\usepackage{animate}
\begin{document}
Hello!
\end{document}

I get this error:

! Missing control sequence inserted.
<inserted text> 
            \inaccessible 
l.18848   \cs_set_nopar:Npn ^^L
                            { }

When instead I use the bigfoot package, I get this error:

! LaTeX Error: Command \c@abspage already defined.
           Or name \end... illegal, see p.192 of the manual.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.56   \newcounter{abspage}
                       %

Is there a way to correct one or both of these errors?

The contents of the .log file after using \listfiles are available here.

3

The error with bigfoot has nothing to do with cprotect; just load bigfoot after animate.

The following document raises no error:

\documentclass[10pt, oneside, openany]{book}
\usepackage{graphicx}
\usepackage{cprotect}
\usepackage{animate}
\usepackage{bigfoot}
\begin{document}
Hello!
\end{document}

Update your TeX distribution.

  • Many thanks! Loading bigfoot and cprotect after animate fixes both problems, even with my old Arch-provided TeXLive. After upgrading it I can also have cprotect before animate exactly as you write. – Konstantinos Mar 17 '16 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.