2

I updated my copy of TeXworks to version 0.4.6 recently, and updated my Miktex at the same time. Since then, it's stopped creating .gz-files, so synctex no longer works.

Ctrl + Click on the source brings the PDF preview to the front, but doesn't find the corresponding location in the document. Trying the reverse (pdf -> source) results in error:

"Cannot read file '[file path without filename]'. Access denied."

There's nothing but plain letters and numbers in the filename and path, and it fails on all documents, regardless of whether the path includes spaces. I created the following document, which still failed to sync, so it's not anything in the content or package clashes:

\synctex=1
\documentclass{article}  
\begin{document}
 anybody home?
\end{document}

PdfLaTeX vs XeLaTex doesn't make a difference. I'm using Windows 8.1. Older documents with .gz-files from before the update work fine. Any ideas on how to fix it?

  • has there been an error message during the updates? what do the log files to MiKTeX say? same for TeXworks. – naphaneal Mar 17 '16 at 20:28
  • @naphaneal No errors or even warnings in the log file after I compile, nor any error messages during TeXworks installation. The system log files from installation are long gone, unfortunately, due to a disk cleanup. – EAG Mar 19 '16 at 13:04
  • Have you tried different editors such as TeXmaker? – naphaneal Mar 19 '16 at 13:10
  • TeXmaker doesn't output a .gz file but does successfully jump between source and output. – EAG Mar 20 '16 at 16:03
  • 1
    I had a friend look at it, and it looks like the $synctexoption argument isn't getting passed over when the doc compiles. He came up with a hacky solution: In the Tool Configuration screen (Edit > Preferences > Typesetting) for each compile method (PdfLaTeX, XeLaTeX, etc), remove the $synctexoption item, then add -synctex followed by 1, and move $fullname to the bottom of the list. Doesn't fix the root of the problem, but it makes synctex happen. – EAG Mar 20 '16 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.