2

First of all, I'm sorry if the question is bad, but I'm desesperate. I'm using the metathesis file that is in this link. The problem is that I entered in the thesis.tex file, and edited it, adding this:

\documentclass[dvips,letterpaper,12pt]{report}
\usepackage{thesis}
\usepackage[utf8]{inputenc}
\usepackage{amsfonts}
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{amssymb}
\usepackage{mathrsfs}
\usepackage{enumerate}
\usepackage{graphicx}
\usepackage{float}
\usepackage{parskip}
\usepackage[all]{xy}
\usepackage{relsize}
\usepackage{tikz}
\usepackage{multicol}
\usetikzlibrary{arrows,chains,matrix,positioning,scopes}

\makeatletter
\tikzset{join/.code=\tikzset{after node path={%
\ifx\tikzchainprevious\pgfutil@empty\else(\tikzchainprevious)%
edge[every join]#1(\tikzchaincurrent)\fi}}}
\makeatother

\tikzset{>=stealth',every on chain/.append style={join},
         every join/.style={->}}

After that, I added some text in the chap2.tex file, and added a xy model, that doesn't appear, that is this one:

\[
\xymatrix{
& & & & & S\ar[dlll]\ar[dl]\ar[dr]\ar[drrr]\\
& & Q1 & & Q2 & & Q3 & & Q4\\
}
\]

But It doesn't show me the arrows of the xy model, so I don't know how to do it. Can anyone help me?

4
  • 1
    I think you are trying to use tikz-cd package
    – percusse
    Mar 19, 2016 at 6:48
  • \usepackage[all,cmtip]{xy} will emulate the standard arrows. But have a look at tikz-cd
    – egreg
    Mar 19, 2016 at 9:13
  • I see the arrow tips.
    – egreg
    Mar 19, 2016 at 16:28
  • 1
    Note that you have to do latex+dvips+ps2pdf in order to get a PDF, with the setup of the template.
    – egreg
    Mar 19, 2016 at 16:44

1 Answer 1

1

It seems as if you are trying to use your template with PDFLaTeX instead of latex+dvips+ps2pdf which is totally ok for your very example her. You just have to remove the dvips option from your documentclass as I have done below.

I also added an alternative using tikz-cd which is much more modern. In order to compile that, you will have to go inside the thesis.sty file and remove the dvips option from the graphicx package. You could also remove that line completely, as you are loading graphicx again in your main document.

% arara: pdflatex

\begin{filecontents*}{chap2.tex}
\chapter{Figures and Tables}
\label{chap:figtab}
\[
\xymatrix{%
    & & & S\ar[dlll]\ar[dl]\ar[dr]\ar[drrr] & & & \\
    Q1 & & Q2 & & Q3 & & Q4
}
\]
\end{filecontents*}

\documentclass[12pt]{report}
\usepackage{thesis}
\usepackage[all,cmtip]{xy}
\usepackage{tikz-cd}

\begin{document}
\pagenumbering{roman}
\thesistitle
    {Metathesis: \\
     A \LaTeX\ template to Typeset Your Thesis for \\
     Submission to the School of Graduate Studies  \\
     \footnotesize{\sl (Changed the title by modifying the file
      \texttt{thesis.tex})}}
    {\emph{my-name} (change this in \texttt{thesis.tex})}
    {Master of \emph{faculty} \textbf{or} Doctor of Philosophy
     (change this in \texttt{thesis.tex})}
    {Department of \emph{dept-name}
     (change this in \texttt{thesis.tex})}
    {\emph{Month Year} (change this in \texttt{thesis.tex}, too)}
\pagenumbering{arabic}
\include{chap2}
\[
\begin{tikzcd}
    & &[-1em] S\ar[dll]\ar[dl]\ar[dr]\ar[drr] &[-1em] & \\
    Q1 & Q2 & & Q3 & Q4
\end{tikzcd}
\]
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .