1

I am trying to create a bibliography in TeXstudio. Here is the code:

\documentclass[12pt,a4paper]{article}

\usepackage{cmap}                   
\usepackage{mathtext}           
\usepackage[T2A]{fontenc}       
\usepackage[utf8]{inputenc}         
\usepackage[english,russian]{babel} 
\usepackage{indentfirst}
\frenchspacing
\usepackage{authblk}
\usepackage{titling}
\usepackage[backend=biber,bibencoding=utf8,maxcitenames=2,style=authoryear]{biblatex}
\addbibresource{biblio.bib}

\begin{document}

\author{Иванов}
\title{Название \thanks{ссылка на грант}}
\date{}
\maketitle
\renewcommand{\abstractname}{}
\begin{abstract}
\label{firstpage}
    \noindent \textbf{Аннотация:} Text of the abstract in Russian.\par
    \vspace{10pt}
    \noindent \textbf{Ключевые слова:} list of keywords in Russian.
\end{abstract}

\section{Первый раздел}
\noindent Гостиная Анны Павловны начала понемногу наполняться. Приехала высшая знать Петербурга, люди самые разнородные по возрастам и характерам, но одинаковые по обществу, в каком все жили; приехала дочь князя Василия, красавица Элен, заехавшая за отцом, чтобы с ним вместе ехать на праздник посланника. Она была в шифре и бальном платье. Приехала и известная, как la femme la plus séduisante de Pétersbourg 1, молодая, маленькая княгиня Болконская, прошлую зиму вышедшая замуж и теперь не выезжавшая в большой свет по причине своей беременности, но ездившая еще на небольшие вечера. Приехал князь Ипполит, сын князя Василия\cite{quiroga2012concept}, с Мортемаром, которого он представил; приехал и аббат Морио и многие другие.\par

\printbibliography
\end{document}

First of all, simply by adding \usepackage{biblatex} entry (without other related to bibliography entries, namely \addbibresource and \printbibliography) the error Extra \endgroup. \begin{document} occurs. When compiling above mentioned code TeXstudio refuses to print the bibliography. There are many other errors and warnings in the log, I don't even know which of them are important for me to mention in this question, so I will list all of them:

line 21: Use of \sortlist doesn't match its definition. \sortlist{
line 21: Extra }, or forgotten \endgroup. \sortlist{nyt}
line 22:Undefined control sequence. \entry{yuste2015neuron}{article}{} 
line 44: Undefined control sequence. \endentry
line 44: Undefined control sequence. \endentry
line 45: Undefined control sequence. \endsortlist
line 15: Extra \endgroup. \begin{document}
: 'babel/polyglossia' detected but 'csquotes' missing. 
line 33: Citation 'quiroga2012concept' on page 2 undefined
line 36: Empty bibliography
: There were undefined references.
: Please (re)run Biber on the file:(biblatex) testdocument(biblatex) and rerun LaTeX afterwards.

Another strange entry I noticed in the .bbl file:

{Missing 'biblatex' package}
     {The bibliography requires the 'biblatex' package.}

Also, when I run Biber.exe on my .bib file the warning occurs:

WARN - Warning: Found biblatex control file version 3.0, expected version 2.9

Adding the .bib file:

@article{quiroga2012concept,
  title={Concept cells: the building blocks of declarative memory functions},
  author={Quiroga, Rodrigo Quian},
  journal={Nature Reviews Neuroscience},
  volume={13},
  number={8},
  pages={587--597},
  year={2012},
  publisher={Nature Publishing Group}
}

@article{reverberi2012deduction,
    title={Deduction without awareness},
    author={Reverberi, Carlo and Pischedda, Doris and Burigo, Michele and Cherubini, Paolo},
    journal={Acta psychologica},
    volume={139},
    number={1},
    pages={244--253},
    year={2012},
    publisher={Elsevier}
}

@article{yuste2015neuron,
    title={From the neuron doctrine to neural networks},
    author={Yuste, Rafael},
    journal={Nature Reviews Neuroscience},
    volume={16},
    number={8},
    pages={487--497},
    year={2015},
    publisher={Nature Publishing Group}
}
5
  • 1
    Could we have (part of) your .bib file? Also, biber does not have to be run on the .bib file, but on the main file.
    – Bernard
    Mar 21, 2016 at 21:31
  • @Bernard I added the .bib file
    – David
    Mar 21, 2016 at 21:45
  • 1
    I compiled your code and got an bibliography. At last your system is not up to date. Which version of biber do you use? WARN - Warning: Found biblatex control file version 3.0, expected version 2.9 tells you that you need biblatex 2.9 with your biber program.
    – Mensch
    Mar 21, 2016 at 22:38
  • 1
    I have no problem whatsoever. I only added \usepackage[autosyylr]{csquotes}, as required by the .log file, and \nocite{*} before \printbibliography. Did you successively run pdflatex, biber, pdflatex (twice)? Note: present version of biblatex it 3.3, and 2.4 for biber.
    – Bernard
    Mar 21, 2016 at 22:41
  • 4
    I'm voting to close this question as off-topic because the problem can no longer be reproduced or is solved by a package/software update.
    – Werner
    Mar 22, 2016 at 0:22

1 Answer 1

2

I fixed the problem by downloading and installing Biber 2.4. Thanks Bernard for your help!

1
  • 1
    In my case it didn't work imediately after the update. But of course, you must run biber at least once to make it work. After deleting all temporary LaTeX files and running LaTeX-Biber-LaTeX, everything worked just fine. May 18, 2016 at 6:54

Not the answer you're looking for? Browse other questions tagged .