1

I'm using the documentclass ttthesis based on book from here. I really like it, but I don't want to have a new page for each chapter. Sadly every approach I tried failed, and now I noticed it's because there is no clearpage or cleardoublepage at the chapters (that's why redefining or ignoring these like described in all answers regarding this topic didn't work out).

Here is the part that redefines the chapters (not my code, just a snippet from the template):

\newlength{\chapnolen}
\newlength{\chapparlen}
\newsavebox{\chapno}
%% Kein ``Kapitel'' bei Kapitelüberschrift
% \renewcommand{\@chapapp}{} allein reicht nicht!
%% \chapter{...}
\renewcommand{\@makechapterhead}[1]{%
  \vspace*{0.2\textheight}%
  %\hrule
  \vskip 15\p@
  {\parindent \z@ \raggedright \normalfont
    \ifnum \c@secnumdepth >\m@ne
      \if@mainmatter
        \savebox{\chapno}{\chapterheadfont\huge\bfseries \thechapter.}
        \settowidth{\chapnolen}{\usebox{\chapno}}
        \parbox[t]{\chapnolen}{\usebox{\chapno}}\nobreak\leavevmode
%        \par\nobreak
%        \vskip 20\p@
      \fi
    \fi
    \interlinepenalty\@MM
    \setlength{\chapparlen}{\textwidth}
    \addtolength{\chapparlen}{-1.0\chapnolen}
    \addtolength{\chapparlen}{-2ex}
    \leavevmode\nobreak
    \parbox[t]{\chapparlen}{\raggedright\chapterheadfont\huge \bfseries #1\par\nobreak}
    %\the\textwidth
    %\the\chapparlen
    %\the\chapnolen
    %\vskip 20\p@
    %\rule{\textwidth}{1pt}
    \vskip 40\p@
  }}

I just can't find out why there even is a pagebreak for each chapter. I also searched the other parts of the template, but didn't find anything.

Has anyone an idea where these pagebreaks come from or, more importantly, how I can prevent them?

11
  • The macro \chapter is defined in the book class, where it starts with\clear(double)page and after a few other things it calls \@makechapterhead, which you are redefining here. You may want to give a look here
    – campa
    Commented Mar 22, 2016 at 13:46
  • but I tried this, this and similar things and it didn't work, there is still a pagebreak Commented Mar 22, 2016 at 13:50
  • Sorry, I can't reproduce the problem with the class and the answers you linked. You may want to provide a full MWE.
    – campa
    Commented Mar 22, 2016 at 13:58
  • I'll try, but atm my document is kinda messy, this will take me some minutes Commented Mar 22, 2016 at 14:03
  • oh well, just noticed while cleaning up that i was missing something from the answer with etoolbox, I have to use input instead of included, that solved it - would you create an answer so I can accept it? or do we want to close as duplicate? Commented Mar 22, 2016 at 14:15

1 Answer 1

2

If you want a \chapter level heading that isn't at the top of the page, apart from stopping the page break you would want a much less flamboyant setting mid-page, so just copy the setting from \section and adjust accordingly.

So...

enter image description here

\documentclass{book}

\makeatletter
% section from book
%\newcommand\section{\@startsection {section}{1}{\z@}%
%                                   {-3.5ex \@plus -1ex \@minus -.2ex}%
%                                   {2.3ex \@plus.2ex}%
%                                   {\normalfont\Large\bfseries}}
\renewcommand\chapter{\@startsection {chapter}{0}{\z@}%
                                   {-4.5ex \@plus -1ex \@minus -.2ex}%
                                   {3.3ex \@plus.2ex}%
                                   {\normalfont\LARGE\bfseries}}
\makeatletter

\begin{document}

\chapter{Zzzz}
\section{Aaaa}
aa
\section{Bbbbbb}
bb
\chapter{Zzzz}
\section{Aaaa}
aa
\section{Bbbbbb}
bb

\end{document}
3
  • I just used the template because it's from someone at my faculty and it's recommended to use it, I don't even really want the space on top ^^ The general style and titlepage are nice so I didn't want to do it entirely by myself just because I don't like the chapters Commented Mar 22, 2016 at 14:12
  • @TheFlow0360 I did not suggest that you changed your template I just showed you a one-line definition of \chapter that did what you asked. I used book in the example because I don't have ttthesis but you said it is based on book so the definition should work. Commented Mar 22, 2016 at 14:16
  • yeah, your answer is totally correct, I just wanted to express that I could also use book directly because I don't need the space, the real problem was removing pagebreaks while still using the ttthesis, but I'm closing this question as duplicate anyways since the problem wasn't related to the template Commented Mar 22, 2016 at 14:51

Not the answer you're looking for? Browse other questions tagged .