0

I am using latest LyX version of classicthesis template.

What I want is the one including the numerical number, which is normal setting under document setting "book": enter image description here

What I get under document setting "classicthesis" is the following one without numerical number: enter image description here

[UPDATE!]

"Document Settings" -> "Numbering & TOC" can only get the subsubsection numbered in Classicthesis LyX file, but not in the generated PDF.

So, any other solutions? Urgent help is appreciated as my thesis is due in less than a week!

  • 1
    Check if Document Settings>Numbering can help you. Having numbered subsubsections is a bad style, if you ask me. – PhilipPirrip Mar 23 '16 at 13:56
  • Thank you, I do want to take your advice in the main text, but I really want to have this subsubsection numbered in Appendix. To ensure consistency of format, I presume I have to change it. – Wendy Mar 24 '16 at 1:55
  • I also wonder that if it is normal for an article to have three levels, why it is not good to let each chapter from my thesis to have three levels too, as it is essentially an article? – Wendy Mar 24 '16 at 1:56
  • I just noticed that your instruction only changes to four digit in LyX file, but not in PDF (remain unnumbered). Do you have any other idea? Thx again. – Wendy Mar 25 '16 at 9:27
2

I don't know how to do it in LyX, but adding

\setcounter{secnumdepth}{4}

to the document preamble does the job.

\documentclass{scrbook}

\usepackage{classicthesis}
\setcounter{secnumdepth}{4}

\begin{document}
\mainmatter
\chapter{A}
\section{B}
\subsection{C}
\subsubsection{D}
Is it numbered?
\end{document}

enter image description here


The code I actually used, having titlesec 2.10.1, is

\documentclass{scrbook}

\usepackage{classicthesis}
\setcounter{secnumdepth}{4}

%% This is only necessary if you have titlesec
%% version 2.10.1 (released 2016/03/15).
%% Version 2.10.2 should fix the bug, which
%% doesn't affect older versions.
\usepackage{etoolbox}
\makeatletter
\patchcmd{\ttlh@hang}{\parindent\z@}{\parindent\z@\leavevmode}{}{}
\patchcmd{\ttlh@hang}{\noindent}{}{}{}
\makeatother
%% End of workaround

\begin{document}
\mainmatter
\chapter{A}
\section{B}
\subsection{C}
\subsubsection{D}
Is it numbered?
\end{document}
  • Thank you so much! This has bothered me for a while. I really love simple solution like this. For LyX beginners: Just copy and paste \setcounter{secnumdepth}{4} to document-> setting->LaTex Preamble, the blank window. – Wendy Mar 25 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.