2

I am trying to make a CV and there is a section where I want to list the projects I have done with bullets, so I use itemize list inside a tabularx environment like this:

\begin{tabularx}{\linewidth}{>{\centering\arraybackslash}p{2.8cm}|X}
2015 - 2017 & \textbf{Title of Master} \textbf{(120 ECTS)}, Specialization\\[1mm]
& Key projects:\\
& \begin{itemize}
 \item Project 1
 \item Project 2
 \item Project 3
\end{itemize}\\
\multicolumn{2}{c}{}\\
2010 - 2014 & \textbf{Bachelor (180 ECTS)}\\[1mm]
& Final grade: 7.51/10.00 - Name of University\\
& $\bullet$ Diploma thesis: \textit{"Name of thesis"}\\
& $\bullet$ Type of Specialization \\%[2mm]
\end{tabularx}

Using the command \setlist[itemize]{leftmargin=*} in the beginning of the document I manage to suppress the indentation of the items in the list with the key projects but there is a vertical space right after the "Key projects" row and one right after the end of the list that I cannot suppress. I tried using the topsep option like in the block below but did not work:

& Key projects:\\
& \begin{itemize}[noitemsep,topsep=0pt]
 \item Project 1
 \item Project 2
 \item Project 3
\end{itemize}\\

Finally, I tried to list the Projects manually, just by adding bullets in front of each one:

& Key projects:\\
& $\bullet$ Project 1\\
& $\bullet$ Project 2\\
& $\bullet$ Project 3\\

which works fine except that the title of the last project is longer that \linewidth and when it wraps, the text starts right below the bullet instead of starting where the previous line starts.

So my question is, how can I globally suppress both the indentation and the vertical spaces created by the list?

UPDATE: This is a part of the code to reproduce and visualize the problem.

\documentclass[a4paper,10pt]{article}

%%%%-------------------------Packages-------------------------------------------
%\usepackage{extsizes}       %package for extra font sizes
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{titlesec}       %package to edit document and section titles
\usepackage{enumitem}       %package to edit the lists
\usepackage{parskip}        %package to suppress paragraph indentation         
\usepackage{verbatim}       %package to comment in/out chunks of code
\usepackage{tabularx}       %package for better manipulation of matrix dimensions
\usepackage{array}          %package that allows an alignement command along with a column width specifier (p-column)
\usepackage{geometry}       %package to tweak the margins and dimensions                             of the page
\geometry{
 a4paper,
 left=10mm,
 right=10mm,
 top=9mm,
 bottom=8mm
}
\usepackage{hyperref}       %package to include hyperlinks
\hypersetup{                %edit how the hyperlinks will appear
 colorlinks=true,
 linkcolor=blue,
 filecolor=magenta,      
 urlcolor=cyan,
}
\urlstyle{same}
%%%%%%%%%%%%%%%%%%----------------- Beginning of the document-------------------
\begin{document}

%-------------general settings for the whole document--------------------

% \url{https://www.sharelatex.com/learn/Sections_and_chapters#
% Customize_chapters_and_sections}
\titleformat{\section}[block]{\large\bf\raggedright}{}{0cm}{}[\titlerule]
\titlespacing{\section}{0pt}{1.5pt}{0pt}
%\setlist[itemize]{leftmargin=*}    % remove the indent from all list items
%\setlist[itemize]{noitemsep, topsep=0pt}
%\setlist[itemize]{nosep}

\pagestyle{empty}                     %non-numbered pages

 %-------------------------Education Section----------------------------------
\section{Education}                  % Section Education
\begin{tabularx}{\linewidth}{>{\centering\arraybackslash}p{2.8cm}|X}
2015 - 2017 & \textbf{Title of Master} \textbf{(120 ECTS)}, Specialization\\[1mm]
& Key projects:\\
& \begin{itemize}
\item Project 1
\item Project 2
\item Project 3
\end{itemize}\\
\multicolumn{2}{c}{}\\
2010 - 2014 & \textbf{Bachelor (180 ECTS)}\\[1mm]
& Final grade: 7.51/10.00 - Name of University\\
& $\bullet$ Diploma thesis: \textit{"The name of the thesis which is long enough that the text wraps but starts right below the bullet instead of starting where the word ""Diploma" starts}\\
& $\bullet$ Type of Specialization \\%[2mm]
\end{tabularx}

\end{document}

So in the first case I cannot get rid of both the indentation of the items and the vertical spaces above and below them. In the second part I just put bullets manually but the name of the diploma thesis is so long that it wraps and looks ugly because it lines up with the bullet and not with the word above.

What I want is the result to show like in the second case but also fix the wrapping problem. I hope I made myself clear. Thanks for the help.

  • Welcome! Please provide a complete example (minimal document) we can copy-paste-compile to reproduce the issue and work on the problem. That's much more useful than fragments of code which leave people guessing how to complete the picture. (And often guesses turn out not to reflect the actual situation, so work solving the problem doesn't actually help anybody.) – cfr Mar 23 '16 at 13:09
  • @cfr I updated my question. You can reproduce the problem now. – nico Mar 23 '16 at 13:33
2

I suppress them within the table:

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[style=british]{csquotes} \usepackage{array, tabularx}
\usepackage{enumitem}
\usepackage[table, x11names]{xcolor}

\begin{document}

\begin{table}[!ht]
  \setlist[itemize]{wide=0pt, label=\color{LightBlue3}\textbullet, noitemsep, topsep=2pt, leftmargin=*, after =\vspace*{-\baselineskip}}
  \begin{tabularx}{\linewidth}{>{\centering\arraybackslash}p{2.8cm}! {\color{LightBlue3}\vrule width1.5pt}>{\arraybackslash}X}
    2015 - 2017 & \textbf{Title of Master} \textbf{(120 ECTS)}, Specialization \\[1mm]
                & Key projects:
    \begin{itemize}
    \item Project 1
    \item Project 2
    \item Project 3
    \end{itemize}\\
    \multicolumn{2}{c}{}\\
    2010 - 2014 & \textbf{Bachelor (180 ECTS)} \\[1mm]
                & Final grade: 7.51/10.00 - Name of University
    \begin{itemize}
    \item Diploma thesis: \textit{\enquote{The Hunting of the Snark. An agony in eight fits}}
    \item Type of Specialization%[2mm]
    \end{itemize}
  \end{tabularx}
\end{table}

\end{document} 

enter image description here

  • Thanks for the answer. I was hoping to do it globally though since I have this in quite a few places. – nico Mar 23 '16 at 13:37
  • That's easy: put the setlist{…} in your preamble instead. I put it within the table just in case you did not want this setting to be general. – Bernard Mar 23 '16 at 13:39
  • B.t.w.: Welcome to TeX SX! – Bernard Mar 23 '16 at 13:40
  • First of all thanks for the welcome. Secondly, i had these two commands in the preamble \setlist[itemize]{leftmargin=*} and \setlist[itemize]{noitemsep, topsep=0pt} and while the first one worked the second didnt. Not even when I commented out the first one. Can it be one of the used packages that overrides that command? And by the way your way doesn't work either. – nico Mar 23 '16 at 13:44
  • Did you try grouping the two \setlists? – Bernard Mar 23 '16 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.