0

I am trying to run sublime text 3 texlive on a windows 10 x64 system. When I compile I get the following message:

[Compiling C:\Users\devin\Documents\LEGrp\tex\setup_instructions\ISUR setup instructions.tex]

TraditionalBuilder: Engine: pdflatex. Invoking latexmk... done.

Output from compilation:

but no pdf file is created or opened. I am using SumatraPDF. I have tried searching for this issue but without any explicit errors it is hard to debug. In my LaTeXTools.sublime-settings file in the "windows" section I have :

"windows": {

        // Path used when invoking tex & friends; "" is fine for MiKTeX
        // For TeXlive 2011 (or other years) use
        // "texpath" : "C:\\texlive\\2011\\bin\\win32;$PATH",
        "texpath" : "C:\\texlive\\2015\\bin\\win32;$PATH",
        // TeX distro: "miktex" or "texlive"
        "distro" : "texlive",
        // Command to invoke Sumatra. If blank, "SumatraPDF.exe" is used (it has to be on your PATH)
        "sumatra": "",
        // Command to invoke Sublime Text. Used if the keep_focus toggle is true.
        // If blank, "subl.exe" or "sublime_text.exe" will be used.
        "sublime_executable": "",
        // how long (in seconds) to wait after the jump_to_pdf command completes
        // before switching focus back to Sublime Text. This may need to be
        // adjusted depending on your machine and configuration.
        "keep_focus_delay": 0.5
    },

Please Help!

1

The fact that you are getting the Output from compilation: line indicates that a log file wasn't generated, most likely because there was some problem launching LaTeX or latexmk. Most likely, since there is no output, there was some problem running running latexmk itself, i.e. the executable couldn't be found had some error running. There may be some useful information in the Sublime console. To see, use the View menu and select the Show Console option.

Another thing you could try is running latexmk from the command prompt. The command LaTeXTools uses looks something like this:

C:\texlive\2015\bin\win32\latexmk.exe -cd -f -pdf -interaction=nonstopmode -synctex=1 "C:\Users\devin\Documents\LEGrp\tex\setup_instructions\ISUR setup instructions.tex"

Try running that from the command prompt and see what happens.

I suppose the most likely cause is that you've installed the minimal install of TeXLive, in which case you will need to run tlmgr install latexmk from an elevated command prompt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.