1

I'm trying to modify my figure placements, but the [H] (and [!ht], etc) isn't working. It has no effect on the figure placement, and I get the text "[H]" added just before the image.

MCWE:

\documentclass{mn2e}
\usepackage{float}
\usepackage{graphicx}

\usepackage[english]{babel}
\usepackage{blindtext}

\begin{document}

    \begin{figure*}[H]
    \centering
    \includegraphics[width=0.8\textwidth]{fig}
    \caption{Some Caption}
    \label{fig:1}
    \end{figure*}

\blindtext[10]

\blindtext[6]

\end{document}

Result:

enter image description here

And I'm using TeXShop 3.6.1 on OSX 10.11.2

  • 2
    The [H] option is illegal for figure*. – egreg Mar 24 '16 at 19:22
  • @egreg... okay, how do you achieve the same effect with figure*? – DilithiumMatrix Mar 24 '16 at 19:23
  • @egreg also, while a normal figure is placed in the correct position, the [H] is still just printed on the page.... – DilithiumMatrix Mar 24 '16 at 19:25
  • mn2e class isn't in texlive it seems? I do not have it. perhaps it is incompatible with float package (which adds H), there is no way to get an H effect with figure*, what would you want it to do? – David Carlisle Mar 24 '16 at 19:28
  • @DavidCarlisle ... I would want it to place the figure above the text, as in the .tex document.... – DilithiumMatrix Mar 24 '16 at 19:34
6

mn2e and its replacement mnras class disable the float options. As with many publisher classes they intentionally remove options from the author to enforce a house style.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.