2

Similar to this question, I have the problem where the hyperref footnote link sends me back to the title page.

I'm trying to add "hyperfootnotes=false" as an option in the LyX > Document Settings > PDF Properties > Hyperlinks menu. But this doesn't seem to do anything. Am I doing it wrong?

enter image description here

  • 1
    If I recall correctly, you must use that option in the original call to hyperref: you can't put it in \hypersetup (so \usepackage[hyperfootnotes=false]{hyperref}, not \usepackage{hyperref} \hypersetup{hyperfootnotes=false}). Can you check to see how LyX uses hyperref? – jon Mar 25 '16 at 5:31
  • 1
    Yes, @jon is right. One way to accomplish this in LyX is to go to Document > Settings and under "Class Options" put "hyperfootnotes=false". This will be picked up by hyperref. Assuming this works for Kenny, jon go ahead and put that as the answer. – scottkosty Mar 25 '16 at 6:06
  • @scottkosty -- Maybe you should answer it (if it is answered) since you can speak about LyX with some real authority. I'd really just be writing what you say on faith. – jon Mar 25 '16 at 6:14
  • @jon I could almost say the same about LaTeX but it is true that I can at least test the solution. In any case, let's see if the proposed solution works for Kenny. – scottkosty Mar 25 '16 at 6:41
2

A solution is to put "hyperfootnotes=false" under "Class Options" in Document > Settings.

The reason, as @jon points out in the comment above, is that the option must be passed for the original loading of hyperref (and not the subsequent \hypersetup command).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.