0

I am using TexStudio but when I tried to compile my file with pdflatex I had the same issues. Only one of my figures is not displayed in the pdf file. All figures are .png. I have tried to switch to .pdf, but it doesn't make a difference. Then I moved the figure a section up, no difference.

Moving few sections up caused an error while compiling:"Undefined control sequence" on my \todo{ something } command. The weird part: it complains only for a few of the \todo commands after the included figure, not all of them, and the picture is displayed.

I'm not even sure what information to provide, because this could be a bug, a package issue and I'm not even sure if I can reproduce it with other files. I have tried to google this bahaviour without success, and hope that someone can help me.

EDIT: these are the error messages on one of the \todo commands

! Undefined control sequence. <argument> ...tally@float \expandafter {\@captype } l.225 ...hown in \todo{ add plot} . ?

! Missing \endcsname inserted. <to be read again> \ftype@ l.225 ...hown in \todo{ add plot} . ?

! Extra \endcsname. \tally@float ...ame ftype@#1\endcsname \endcsname \@ifnotrelax \@tempa {\@if... l.225 ...hown in \todo{ add plot} . ?

When the figure is at the right place, but not displayed, I can't find anything in the log files close to it's lines.

  • 3
    It's more likely to be an error in your file than a package bug. start by showing the full error message from the log from ! to ? Add it to a code section in the question, so that lines endings are preserved in the message. – David Carlisle Mar 26 '16 at 18:43
0

It was a package issue, no idea why but commenting out the todonotes package solved everything.

%\usepackage[colorinlistoftodos,prependcaption,textsize=tiny]{todonotes}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.