1

I am trying to use the glossaries package to create a list of symbols. I've almost succeeded, but I run into a strange error. Here is a minimal working example:

\documentclass{report}
\usepackage{lipsum}
\usepackage[acronym,nomain]{glossaries}
\usepackage{glossary-longragged}
\glossarystyle{longragged}
    \newglossary[nlg]{symbol}{sym}{smb}{List of symbols}
    \makeglossaries
   \newglossaryentry{Ffriction}{
        name={Friction force},
        description={\lipsum[1]},
        symbol={\ensuremath{F_\mathrm{friction}}},
        type=symbol
    }
\begin{document}
    \gls{Ffriction}

    \glssymbol{Ffriction}

    \printglossary[type=symbol,style=altlongragged4col]
\end{document}

When I run pdflatex, makeglossaries and pdflatex again, I get the following output:

enter image description here

The \gls{Ffriction} command prints the name of the entry as it should. But \glssymbol{Ffriction} prints “ensuremath –F˙“mathrm –friction˝˝, instead of the actual rendered symbol. The symbol looks just find in the glossary itself:

enter image description here

What am I missing? How can I fix this?

7
  • Off-topic: Use \setglossarystyle -- glossarystyle is deprecated. As it stands, I can't reproduce your issue here
    – user31729
    Mar 29, 2016 at 17:56
  • You can't?! I'll try if I get the same output with normal latex instead of pdflatex. Off-topic: what should I use instead of glossarystyle?
    – jkokorian
    Mar 29, 2016 at 18:18
  • \setglossarystyle, as I wrote above. And no, I am not seeing the strange output.
    – user31729
    Mar 29, 2016 at 18:19
  • 1
    I have no clue at the moment. Do you have the latest version of glossaries? It's version 2016/01/24 v4.21
    – user31729
    Mar 29, 2016 at 18:24
  • 4
    I'm voting to close this question as off-topic because the issue could be solved by updating the glossaries package(bundle)
    – user31729
    Mar 31, 2016 at 4:09

0

Browse other questions tagged .