2

I see a problem where biblatex omits the author name and year in repeated citations when page numbers are used:

\documentclass{article}

\usepackage[backend=biber,authordate]{biblatex-chicago}

\begin{filecontents*}{foo.bib} 
@article{denning2010computation,
    AUTHOR      = {Denning, Peter J.},
    TITLE       = {What is Computation?},
    JOURNAL     = {Ubiquity},
    YEAR        = {2010},
    DOI         = {10.1145/1880066.1880067}
}
\end{filecontents*}
\addbibresource{foo.bib}

\begin{document}

First citation \autocite[2]{denning2010computation};
second citation \autocite[4--8]{denning2010computation}.

\end{document}

This renders as follows:

enter image description here

But I want it to render as

First citation (Denning 2010, 2); second citation (Denning 2010, 4-8)

How can I disable the omission of the name and year? Preferred facultatively, but possibly globally.

  • Have you tried adding the (global) noibid option? What does 'facultatively` mean? (Optionally?) If you mean on an ad hoc basis, then compare not loading the noibid and for your second \autocite putting a \mancite first (e.g., \mancite\autocite[4--8]{denning2010computation}). If neither of those work, I'll need more explanation of what facultatively means to you. And of course, there's also \autocite*{<key>}, though it will not do what you want out of the box. – jon Mar 30 '16 at 0:30
  • @jon Yes, ad-hoc. Both proposals are perfect, thanks, please post as an answer. – Emit Taste Mar 30 '16 at 0:41
4

There is both a global and facultative solution available.

The global solution is to use the noibid option at package load time:

\usepackage[backend=biber,authordate, noibid]{biblatex-chicago}

The ad hoc solution is to precede your citation commands with \mancite:

second citation \mancite\autocite[4--8]{denning2010computation}

(Note that there is also \citereset, which 'resets' even more trackers than \mancite. It is most useful if you want to restart citation trackers at the start of the section.

Full example:

\documentclass{article}

\usepackage[backend=biber,authordate, 
%noibid % <-- uncomment if you want to disable `ibid` globally
]{biblatex-chicago}

\begin{filecontents*}{foo.bib}
@article{denning2010computation,
    AUTHOR      = {Denning, Peter J.},
    TITLE       = {What is Computation?},
    JOURNAL     = {Ubiquity},
    YEAR        = {2010},
    DOI         = {10.1145/1880066.1880067}
}
\end{filecontents*}
\addbibresource{foo.bib}

\begin{document}

First citation \autocite[2]{denning2010computation};
second citation 
\mancite % <-- comment out to see default behaviour
\autocite[4--8]{denning2010computation}.

Note that \autocite*[2]{denning2010computation} is unaffected by the \verb+noibid+ option\ldots

\end{document}

If you need to use \mancite frequently (but not all the time), you might want to define a new citation command for this purpose:

\DeclareCiteCommand{\myautocite}[\mkbibparens]
% this is just the \parencite command (of biblatex-chicago) + \mancite
  {\mancite
   \usebibmacro{cite:init}%
   \usebibmacro{prenote}}
  {\usebibmacro{citeindex}%
   \usebibmacro{cite}}
  {}%\setunit{\multicitedelim}
  {\usebibmacro{postnote}}

\DeclareMultiCiteCommand{\myautocites}[\mkbibparens]{\myautocite}%
   {\setunit{\multicitedelim}}

\newrobustcmd*{\Myautocite}{\bibsentence\myautocite}
\newrobustcmd*{\Myautocites}{\bibsentence\myautocites}

This gives you \myautocite, \myautocites, \Myautocite, and \Myautocites. (Although I am not sure the last two are of much use in Chicago's author-date citation style.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.